Saving data from external database through SQL Database Connector

Dears Bubblers,
I bring seven different records from the API (external database) but when I hit the save button, the application is creating seven things, repeating all the records in each one, but it is necessary to create one thing for each record.

Please who could help me to fix this?
A lot of thanks!!!
@solutomn

Custom State:
state

Repeating Group birng data from external database:
RG xternal database

Save button step1:
save button 1

Save button step2:
save button 2

Backend Workflow:
endpoint
endpoint 2

Database wrong saved:
bubble database worng saved

Can you show the setting of your “DI_numero” field in your backend WF?
You can consider checking data provided in Logs Tabs in your app (scheduler sub tab). Actually I think your error is in Scheduled Create a new thing action that may not correctly filter the item you currently want. In the Scheduler logs, you will see if you are sending only one number or a list of number too.

Hi @Jici
Veja se é isso que você pediu?
image

I mean in your WF action Create a thing. You seem to call the API Again

Would be the below?

If you click “Consulta_di’s Numero_di” in the DI_numero field, what is the setting there?

That’s it?
image

Yes. I think this is probably your problem. I guess you should current use something from the Backend WF Endpoint and you have not using it. When you create your "Schedule on a list " action, you set one field: “di” that is This text. So it should provide the current item from the List of int-state. But you are not using this value in process / create a thing action.

Do you mean here?

This is correct I think.
I mean that in your scheduled API Workflow, you have a field that you set usting this state. This is all correct, but you are not using this field into your Backend WF. Check in your Backend WF and you should see a parameter “di” . You should use this probably somewhere in your Create a new thing action

@Jici
Thank you very much!!! You helped me a lot. See, it worked!
image

2 Likes