Saving 'raw body' text from API call broken

I have just struggled with this for about 3 hours. I finally figured out that you need to set up your api in the backend workflow with the correct steps.

  1. Make sure you select Include headers in the detected data first.
  2. Click detect data and wait for incoming webhook to populate fields.

Make sure you do not untick the “Include headers in the detected data”. You will now have access to Request Data’s raw body text
Shared with Zight

I wish they just hid that option “raw body” if you did not have it set up correctly. It was so confusing trying to figure out why I couldn’t access the raw body on an existing API.

It does not work simply checking Include headers in the detected data on an API if you haven’t actually detected the data without that box checked!

If you do not follow these steps and want to convert your Bubble API (backend workflow) to capture the raw body, you will need to redect the data with that box checked. This will cause issues for every step in the workflow that references the Request data. So be prepared to fix all these once you do this.

2 Likes