Forum Academy Marketplace Showcase Pricing Features

Sendgrid API Not Working

Hey @copilot,

Do you mean the topic I mentioned in June: Sendgrid API Not Working, or is it something different?

You replied you were on your way to upgrading with no ETA (Sendgrid API Not Working). Are you still on the same way?

If this doesn’t require any actions on your side, how would you suggest to overcome the issue? From what you said a lot of people had the same problem and the root problem was the same, so hopefully you know what to do by now.

Also, as I mentioned in my original message in this thread the call worked perfectly fine via Postman, only Bubble + the plugin combo returned errors, so I’m not sure if this is something I did wrong or the plugin works differently for everyone and some people get unlucky.

Thanks in advance,
Andrey

Hi everyone,

are there any updates on this topic?

We´ve a similar problem. We send a lot of e-mails via the sendgrid api and everything works perfectly except one. It´s send from a reusable element and we get this message (see screenshot). Any ideas?

Thanks in adcance,
Matthias

Bildschirmfoto 2021-01-18 um 11.20.26

2 Likes

IF it helps anyone, I just had this problem and reported a bug to Copilot. In my case it was the TO email address that was dynamic and dynamically bringing in a blank value (that records did not have an email address). I added the email address in the record (thing) and it worked! Hope that works for you too.

2 Likes

My problem was also related to the To: email being dynamic and maybe blank or not loaded yet.
Thanks for mentioning this.

Me funciono!!, si alguien necesita ayuda el problema del loop, fue el mail, cuando lo escribía directo funcionaba el envio, cuando lo hacia como loop era el problema. La solución era de donde venia esa lista, yo le indicaba que era “current page user” y ahí estaba el error debía enviar a través de el RG asociado.

Saludos

Hey everyone, sorry to revive this, but it seems there is still no clear answer to this problem, which I am also having.

I did go through the entire thread above and have tried:

  • Submitting a bug report to copilot. No response.
  • Double checking that all users have a name and email field.
  • Checking that the recipient is This User and not Current User.

Here’s the error log:

Frontend workflow:

Backend workflow: