Forum Academy Marketplace Showcase Pricing Features

Sendgrid help needed

Sendgrid has some annoyances, like the fact you can switch off Two-Factor Authentication, but as soon as you try to log back in you are told you must have Two-Factor Authentication to log in.

I also find their layout confusing, notice how you can create templates from the Design tab or the Email API tab, who designed this UI! See below:

Moaning out of the way, I will now walk you through my setup (and the issue).

I have my own business domain and email. I’ve created a Sendgrid account, the API has been added to Bubble;

I’ve created a very simple dummy email template:

and here is the Template ID

My Bubble page looks like this;

4

and the workflow has the Template ID (note: I am using a sendgrid plugin).

There is only plain text, all I want to do is get an email to send and be received (for now).

When I fill out my email and click the green 'Send reset link’I get this error;

error

Later on I received an email from sendgrid saying;

A message was received from this address by our systems that had errors in the SMTPAPI header, and cannot be processed due to the following:

The template id must be a valid template id for your account. You provided d-32bd3b488d0c44e0aaca0fc296f639be

Can anyone help?

Are you just looking to have password reset emails sent then? If so, why can’t you just use that action within Bubble itself?

Bubble’s built it reset password returns “Oops, this doesn’t look like a valid email:”. I tried everything so had to try sendgrid. To be fair, I will need sendgrid anyway for my app so figured I’d just try and get that working.

Can you send a full screenshot of the Send Email action you’re using?

Make sure you’re using a Legacy Template. I believe this is the issue I hit when trying to use a new template or one of my own. SendGrid only works with the Bubble internal implementation using the Legacy Templates.

There’s not much more info than I had put above, the send email action is this;

The only thing which isn’t showing is that the email is sent to Current User’s Email.

Have you granted proper access in your Sendgrid API key?

Yes, I tried Legacy but is doesn’t work, I get this error;

error

I have yes.

Thank you everyone but I am now going to pay someone to fix this as I have tried everything I can think of. I will post the results if there is anything that I missed so others can learn too.

I’d have to actually be in front of the app working on it to figure it out the issue

While it is completely fine paying someone. I just wanted to show our Youtube Video about sendgrid. Maybe it is helpful for you or for someone else in this community.

Yes I know, some things are not easily transferable to a forum question. I defo appreciate the input and the community support.

Thank you, I will check out the video - thanks for sharing.

@darren.james7518 Judging from the screenshots you posted, it seems two things are missing:

  1. You correctly added the API key to Settings > Domain/email, but did not add the key to the SendGrid plugin in Plugins. You’ll need it there in order to be able to use the plugin action such as ‘SendGrid - Send email (custom)’.

  2. You also have to connect SendGrid to the domain your app uses by setting up the DNS at your domain registrar’s website as instructed by SendGrid or nothing in Bubble will matter.

Other than that, your setup looks good to me. :+1:

Thank you. I have set up my Godaddy DNS settings but I just realised that I am using a business email address from Google. For my business email to work with Google Workspace, Google MX records have to be set up and configured for your domain, but I can’t find where to change the DNS settings in Google admin console - does anyone have a screen shot or something because most tutorials are out of date and show a different (older) Google admin console?

@darren.james7518 I use neither GoDaddy nor Google Workspace, so I’m afraid I can’t really help with that. Perhaps someone else can chime in here.

If no one does, I’d suggest googling something like “set up both sendgrid and google workspace dns”. This is not a Bubble issue and I’m 100% positive you are not the first one who encountered it, so there must be a detailed workaround on StackOverflow or some other site.

The best of luck and remember to post the solution you find here so future Bubblers who bump into the same problem may refer to it!

Thank you, I will continue trying to find a solution and will post here!

1 Like

Since I now know this is a specific issue relating to the combination of Sendgrid and Google Workspace, I have posted to new thread here