Forum Academy Marketplace Showcase Pricing Features

SendGrid - Send email workflow

I have recently set up SendGrid… it has been set up and the test e-mail came through no problem, with the selected SendGrid template.

However, when I set it up in a simple workflow to send email when button clicked, I get this error message…

1484327506287x474510747987607550 error: this header value for Authorization is not correct null

Anyone know what the problem might be? I used the step-by-step debugger, but can’t get past this error message.

For future reference, in case anyone is looking, you don’t need to use the work flow Plugins > SendGrid API - Send email

Confusing! I have no idea what that is for, but the Email > Send email workflow, appears to work fine using the SendGrid template (with the info put in your Settings > Domain & Email > Email Settings). Cheers.

From your screenshot I believe it may be related to the fact that you´re not referencing a TemplateID in the SendGrid action or that there currently is an issue with the SendGrid API http://status.bubble.is/. For this to work, you have to create a template inside SendGrid and then reference that template ID in the SendGrid API action.

In my case, I do use the plugin for the SendGrid API because I have around 30 different transactional email templates and find it easier to manage the templates in SendGrid and just passing the variables and template ID than handling everything inside Bubble.

2 Likes

Hey @mikescullion,

You’ll need to create a template in SendGrid and use that template’s ID for the SendGrid action. If you’re looking for a more basic email, give the ‘Send plain-text email’ actions a go. Using the SendGrid plugin gives you more control of templates, variables, custom arguments among other things. Like Stripe.js, our approach is driven by idea of exposing more native features and direct control of external services rather than letting Bubble get in the way. It’s also fun to know our integration of SendGrid came before Bubble’s switch. :wink:

2 Likes

Thank you both for your help. :slight_smile:

So I know this says solved, but for those that are still having problems, make sure you’ve put:

bearer [your_sendgrid_api_key]

for the “authorization (shared headers)” field when you navigate to plugins >> Send emails with sendgrid

3 Likes

This topic was automatically closed after 70 days. New replies are no longer allowed.