Simple visible condition not working

Hi,

In my app, I want a business plan link only to be visible when a User has uploaded a business plan.
I have 2 types of things, Company and Company Docs. (A field within company docs is company)

Currently the link is not visible on page load.
the condition I want to define is When Current Page company’s Business Plan is not empty (i.e. a user has uploaded one), the link will be visible for other users.
What am I doing wrong??

Thanks

It’ll be easier to help if you can shar ea link to your editor. This looks like an issue with how your data is set up. Is “Company Docs” a list of things?

How does one share a link to editor?
Yeah, company docs is a list of things within companys but its also its own thing type.


The expression I want is, if the company doc (part of this company and has the name business plan), upload field is not empty - then show this link button.

Thanks for your help,

If you go to Settings > General > there should be an option to change visibility. Make sure it’s either set to others can edit or others can view.

Then, just copy the browser’s URL from the editor window and paste it here.

Does this work:

Yes, that worked. I’m in there now!

cool - can you browse the app yourself or do you need me to guide?

I have a couple questions right off the bat.

In the table for “Dataroom,” why are you not using “current cell’s document?”

Where’s the spot you’re looking for help? I can see you poking around, but I can’t see where the business plan download link is.

I tried that before and it wasn’t working so I began to search for the company docs specifically - have changed it back now.

this is actually another issue i have been trying to resolve with another user

Ok, I’ll respond on that thread for that topic.

Let’s focus on the visibility issues on this one!

Ah - the spot is Company Profile page - element is Group Tab 4 Content

Where is the Business Plan actually saved? I don’t see a field on the Company called, “Business Plan” anywhere.

Saved in ‘company docs’ thing.
All uploads for companies are saved there - part of the reason is due to the other thread

If you go to App Data -> company docs -> you’ll see one.

Ok, lemme go read through the other thread. This data set up is foreign to me. Checking that thread now!

okay - cheers for your help so far!

Ok, so there are two things you can do here. One of which involves restructuring your database again, so let’s avoid that.

To make the visibility work, here’s the condition I would use:

Do a search for Company Docs (company = Current Page company, name = Business Plan):Count = 0

Then visibility is no. Does this make sense?

2 Likes

Okay - so I did that but rather when count = 1, element is visible (there is no option to make element invisible)

Nope - it works !!

any chance you could have a look at the other thread?
thank you so much for all this

This topic was automatically closed after 70 days. New replies are no longer allowed.