Forum Academy Marketplace Showcase Pricing Features

Slideshow crop to fit

Is there a way to get the image in the slideshow to expand to fill the widest dimension of the slide area and crop the rest of the image? The only two options I see are stretch, which is hideous and I’m not sure when anyone would ever use it, or rescale, which proportionally resizes the image to fit the narrowest dimension of the slide area. The rescale is okay but it leaves a lot of white space and it’s not very responsive.

In some elements there’s the option to crop the image so it fills up the image area. Is there a way to get the slides to do that?

See, in this example I don’t need to see the entire image. I’d rather fill up the area by cropping the image down to fit the wide area.

2 Likes

So, I found that the element which lets me crop the image to fit is a group if the image is set as the background.
I covered up the slideshow with a group and dynamically set its background image to the slideshow’s slide’s image.
When the slide’s transition is set to 0 (so it’s instantaneous) the group switches between images like a slideshow.

Thing is that since there’s no transition (fade, slide, etc) it’s a really harsh slideshow. Either there’s a white flash between images or the images just hard cut into each other. Neither is comfortable to watch for any length of time.

Any ideas on how to make this newer, more responsive slideshow transition gently between images?

Yeah Slideshow isn’t useful for full screen. Would love a solution too.

1 Like

I have the same problem, I am not sure if anyone found a solution to this yet?

Hi Guys,

I have raised a bug for this with bubble. Hope they come back soon.

Regards
Meenakshi

2 Likes

No news about it?

Same issue

Anyone found a solution to this?

1 Like

I know that this is an old post but maybe someone is still interested in a solution. The trick is to set the type as image and not as as custom data type. Then you can add at the end of the search the “processed with Imgix” with the “resize to fit” option active. Leave the rendering mode as stretch and the image height will auto adjust itself. Hope this can be useful :wink:

Schermata 2021-02-23 alle 11.00.48

Anyone found the best solution to this yet?