Snov.io Domain Search V2 not working

I use the API service snov.io in my application.

I received an email today from Snov.io saying that their Domain Search V1 API call is being full deprecated on Aug 31st, 2020 and I need to switch to Domain Search V2.

It seems straight forward enough, but while the Domain Search V2 API call initializes properly, every workflow step following this the Domain Search V2 action does not run.

Does anyone have any idea why an API call action that initializes properly would somehow cause subsequent actions to not run?

I submitted a bug report to Bubble and a Bubble support engineer was able to recreate the error. He suggested a work around, which worked.

The Snov.IO API documentation only clearly states that one parameter (lastId) is required, leaving me to believe the parameters “type” and “limit” are optional, as they were in Domain Search V1.

So while in V1 it worked to mark three of the input parameters are optional.

In V2 is was necessary to mark none of them as optional.

That resolved the issue.

1 Like