Forum Academy Marketplace Showcase Pricing Features

[SOLVED] Getting 404 with an api call

I have an API endpoint called create_tweet inside of an application called cuapi.

I try triggering the workflow using curl:

curl https://cuapi.bubbleapps.io/version-test/api/1.0/create_tweet --data "contentyo=yolo"

but it returns the following json:

{"statusCode":404,"message":"Not found"}

I am brand new to Bubble and there’s probably a few reasons this could be happening. For one, I don’t think I specifically declared this to be a POST endpoint. I couldn’t find anywhere to do that. I just assumed that since an object is being created, Bubble knows. I tried issuing a GET request with curl but got the same json results.

Does anyone know what I’m doing wrong?

A workflow is always a POST endpoint. Can you share a link to the editor?

I’m trying to find where you can post a link to the editor, but I don’t see that option anywhere.

Juste paste it here.

Oh actually looking at

curl https://cuapi.bubbleapps.io/version-test/api/1.0/create_tweet --data "contentyo=yolo"

you forgot /wf/

it should be

curl https://cuapi.bubbleapps.io/version-test/api/1.0/wf/create_tweet --data "contentyo=yolo"

Thanks! I don’t see wf in the documentation. Is wf short for work flow? Should this be for all post requests?

It is in the docs, search for “General Workflow Endpoint”

1 Like

Awesome, thank you