Forum Academy Marketplace Showcase Pricing Features

[SOLVED] No API options in privacy rule for some of my data types

For some of my data types I do not have the options to allow modifying, deleting or creating via API. Anyone else experienced this and know how I fix it? This seems to be affecting my most recently created data types, but does affect some data types which I created a while back

Here is what I normally see:

And here are the options I’m getting on the data types where I cannot see API options:

I don’t know exactly how that works, but I believe it has to do with the API settings in the settings tab.

You have options there to select which data types in your bubble database you allow to be accessed via API

When I set it like this below

I get the option in my privacy as below

Learn More

Boston85719 is an expert Bubbler with a decade experience as an educator. Real name Matthew, he has been actively building SaaS apps, marketplace apps, scheduling apps and more for clients, himself and for sale as templates.

As an official Bubble Bootcamp Instructor, he leads Bubble Bootcamps on a regular basis.

Always willing to offer advice via the Bubble Forum, Matthew also offers Private Personal and Group Training Sessions.

Through his site, NoCodeTrainer, Matthew provides a range of tutorials with editor access to help you jumpstart your Bubble development.

Always accessible you can send Matthew a private message via the forum or send an email directly with your requests.

Be sure to checkout the Stripe Integration Course when you are ready to integrate Stripe payments to start monetizing your application via product sales or subscriptions.

Stripe Integration Course

NoCodeTrainer.com

2 Likes

Thank you! That’s solved it :slight_smile:

1 Like