Forum Academy Marketplace Showcase Pricing Features

<SOLVED> Strange Logic Bug

Alright everybody, I have a strange logic bug that I’m not finding a solution to. Before we get started, here is the link to the editor (I’ll make it unavailable once we solve it): https://bubble.io/page?type=page&name=user-dashboard&id=stimpack-labs&tab=tabs-1

To play with it, go to http://stimpack-labs.bubbleapps.io and login using email: [email protected] with password bubble2016

Anyway, here is what’s happening:

  • User must “accept” the NDA to use the site.
  • If the user doesn’t, we set the field of “signedNDA” to No in the user’s DB, and log the user out.
  • If they do accept, the field “signedNDA” is set to yes, and the popup shouldn’t show again.
  • When the user clicks the “upload new video” button, a modal appears.
  • Select any file, then hit “Finish”
  • The modal goes away, but then the NDA modal appears again, even though the user’s signedNDA field is set to yes!
  • When I click “I accept” on this modal, it wipes out my uploaded files, but…
  • When I refresh, everything works as I expect it to. Until I do the add video thing again.

The strange thing is that all the data in the DB is correct. There isn’t any field being set incorrectly, so I’m really weirded out by this. Any help is appreciated!

Further diagnosis: it’s not a problem with the NDA modal, it’s a problem with the file upload.

I removed the modal from the equation, but when I click “Finish” in the video upload flow, that’s when things get wonky. I’ll keep poking and update here when I find the issue.

Edit:

It’s almost as if the page forgets who the user is. It acts like any of the properties I’ve set on the user aren’t real anymore, until I navigate away or refresh.

Is it because you have no user logged in, so current user doesn’t mean a lot.

There’s an email address in the top right corner that’s current user. I’m always logged in as [email protected], and when I use the Bubble inspector in step-by-step mode, I can see all the correct data on the user. It just looks like Bubble is ignoring it.

I’m going to go ahead and file a bug report, too, but leaving this open for others to take a look. Thanks for looking!

One more interesting note: I re-enabled the NDA modal because I remember I dynamically pull the User’s first and last name as content in the modal. When the NDA modal pops back up after I upload a video, the name doesn’t appear! I think after the upload, Bubble forgets who the user is or something. My app has short-term memory loss!

One thing i notice, is you are entering text string in the quotes. On my app, I do not include the quotes as these get stored in the database. Maybe things are getting confused.

So maybe try changing the “yes” and “no” to simply yes and no in the various places. The field is of type Yes/No, but you are trying to write a String of “yes” or “no”.

Ok, it was solved. The problem I had was due to some rogue privacy settings I made. It’s clear to me I don’t understand enough about how Bubble handles the privacy settings, so this is what I get for mucking around in there. Quick support from Emmanuel and team resulted in me fixing the issue.

I’ve set the project back to private and reset passwords, but thanks for playing!

1 Like