Forum Academy Marketplace Showcase Pricing Features

[SOLVED] Strange page loading bug. Calling for my fellow bubblers to help me debug this mystery

The issue was a rounding error when calculating a formula.

To solve it, we first changed one variable at a time to find the culprit.

Then we broke the formula apart and tested each part individually. That’s where we found the rounding error when subtracting the current date to a previous date. Despite changing the dates to 00:00:00, there was still a small discrepancy when changing time zones.


Here’s the case: page not loading a “Search for” in some cases. It works great for some people, not for others. It almost seems like the “search for” times out for some people.

How it should look:

Hot it looks to some people

I have NO idea why, and not sure how to debug it because I can’t replicate it. I’ve tried different devices, wifis, had friends try it, to no avail.

What it should do:

  • When the page loads, I add data to a group. I search for the fitness routine of day, then load up the image, title and category of that routine in that group.

What are the symptoms:

  • For those that it doesn’t load, apparently it wont load in ANY browser and any device. Could it be a wifi thing? Could it be a country thing?
  • The odd thing is, for the people that the home page doesn’t load, specific routines DO load!

What I’ve tried so far:

  • Tried to add a safeguard that checks once the page is fully loaded, if the group is empty. It if is, I tried to reload the data (This didn’t work.):

Other’s have suggested that it’s a country thing, or an ISP issue.

My setup

  • Everything is hosted in my Bubble app, including workout videos
  • Today’s routine is calculated from a specific “Epoc date” and calculate days since to know which routine index should be shown today. Nothing fancy.

I’m at a loss as to what’s going on here. Would be happy to get a few of you to look inside, see if you can figure it out.

I remain hopeful for the power of the community!

I’m happy to help trouble shoot, but not sure how I can. Let me know what you need me to do as I get this:
(I’m in NYC)

1 Like

I’m seeing the same things as @SerPounce. I’m in North Carolina, and have a solid connection.

I don’t think it is an ISP, Wifi or country issue.

There is a loading issue with Bubble that manifests with a 524 error. This may be related, IDK.

Happy to help if I can.

1 Like

What do you mean that when the page loads you add data to a group? Can you share that workflow (or is it the reload below)?

1 Like

Ok, I’ve tried to access on every combo of device and wifi/5G. No cigar on anything. I have Sprint on IOs and my wife has Credo on an Andriod in addition to Mac and PC.

1 Like

Maybe it is a timezone thing? If your search query is fetching items based on a “day’s since” / fixed epoc date. Maybe some users machines date/time doesn’t fall within the right day of the search query?


This is interesting. Could it be a time zone thing?

@SerPounce and I are both Eastern Time

I am also EDT timezone - I see the same issue. The images/videos don’t populate on homepage.

But the specific routine that gets fetched directly from the unique id - that works properly for me

Wow everyone, did not expect such a wonderful response!

Hey thanks for helping me troubleshoot. Could you run: see if anything jumps out?

Hey thanks for the help Robert. Curious, where are you seeing this error?

Sure, it’s not a workflow, just a data source search:

This is interesting. My “Epoc” date is an arbitrary date I set and store in the DB:

I do it this so I can adjust the date if needed (for offsets).

Ok, this is very interesting. Perhaps it is the Epoc date. hmmmm

Ok, so I tweaked the epoc date. However, realizing that the Data Source search is quite heavy to do for each of the three groups (three daily routines), I’m now saving the search in a state and loading the index from there. So 1 calculation for all three groups.



Does this fix it for you guys?
@robert @SerPounce @jordanfaucet

Sorry no, both test and live are still just empty bonfires.

Unfortunatley no - that does not fix it.

Based on your logic if you have 16 routines in your database; your index today would = 0. Maybe it’s a July 31st error? : )

I would consider doing something like

Do a search for routines:random item.
routines day = current day (formated as “Monday”)
type = toning

then have like 3 toning exercise with a day that = monday

Let’s try isolate what the problem is. Replace your current search with something way simpler. Like just the first 3 vids. If that works, then we will know if it’s the search or something else.

117 routines, an equal number for each category: cardio, strength, and toning. I’m using an ordered logic to sync it up with the iOS app. So keeping a specific order, and having the routines cycle around once they reach the end of the list (hence the use of the modulus). Or did you mean just for testing purposes?

Great idea. I’ll set it up on the test! :pray:

hmm fair enough. So unless I am reading your logic wrong; you should be fetching the workout routine (index=16, modality=toning) assuming 117 records.

I don’t know man.

I also thought maybe privacy rules? But it doesn’t look like a user has to log in or anything, so I kind of dismissed that idea.

1 Like

Now this…


AJA! I set up the search for just a single index value for that one item. *Instead of the complex modulus calculation


Progress! Now you know it’s the search, right?

1 Like

WOOOO! Ok, gonna try something different with the search and ping you asap.