Forum Academy Marketplace Showcase Pricing Features

"Sorry we ran into a temporary bug" when submitting to app store

Hi all,

Has anyone experienced this and found a good fix?

I am getting the same since 2 days. No solution yet

On the app store as well? If so, which wrapper are you using?

If have found the root cause of the issue, in the context of my app.

I was using a timer feature in the custom javascript plugin. I used that plugin because I was facing an issue in a workflow.

In that workflow I was doing a STEP1 (update in the database) and then a STEP2 (calling a custom event that was reading the database and performing a calculation, at end of STEP2 a STEP3 was called, also in a custom event, where the result was shown on the screen).

The issue was that when coming to STEP2 the STEP1 had not been completed. I could see that if putting a breakpoint on STEP1, STEP2 was working.

I put the timer in a custom javascript (waiting 200 ms) and it worked but afterwards I would have the error “Sorry we ran into a temporary bug” a bit later on at a random time.

I removed that javascript step and replaced it by something else which worked. What I did was re-trigger a second time the custom event STEP2 inside STEP3, to avoid recursive calls I used a custom state flag. That change created sufficient time for STEP1 to complete before STEP2 was launched the second time.

For the record, here below the javascript code I was using for the timer:

function wait_a_moment() {

bubble_fn_wait_a_moment(result);

}

var result = 1;

setInterval(wait_a_moment, 200);

Were you submitting to the app store or just on the web?

This issue was just on the web app

This topic was automatically closed after 14 days. New replies are no longer allowed.