Stripe.JS works in copy app but not original

Hello @copilot

I have an odd situation. I’ve updated to Stripe.JS 2 for my app. Many of the features dont seem to work for me, like the StripeElements feature.

However I’ve made two copies of my original app, and the plugin work fine there.

I’m wondering if anyone has encountered an issue like that and how would one go about addressing it?

Thank you

Hello again, it seems to be working now almost immediately after I posted this.

To give more detail, one of the issues that I was having was that in my original app, after updating the plugin, I deleted the fields I made to collect credit card information and added the StripeElement’s object in its place, as demonstrated in your training course. However, whenever I ran the page it would not appear. This has been happening for like a day or two.

So I duplicated the app and its database so it was exactly the same. I didnt even have to change anything. When I ran the page for the copy app, the element fields were right there. Like I said, I didnt have to do anything different at all.

For the original app, I refreshed the editor a bunch of times, restarted the web browser completely and eventually even restarted the computer. No luck.

Then I made this post, but without me making any new changes, my app’s run page said that a change was made and to refresh the page, and after a refresh, now it works. Another thing of note, the only thing I did differently this time was select another element in my editor and then return to the previous element with the StripeElement.

So it seems to be working now. Could it be possible that my original app was somehow being prevented from using the API somehow? Like maybe some accident or hiccup with connectivity?

Thank you