Table conundrum - data not always loading

This one has me beat!

The 2 screen shots below show a Table and a Repeating group. The Rpt Group has just a check box and the name but here’s the thing:

In the second shot the ‘names’ disappear except in the first Table row…but only sometimes! At other times they re-appear. The Rpt Group is faultless and never fails to show the names.

The first shot shows when it decided to work.

In the table I have other checkboxes which change the ‘User record’. But, even when the name isn’t showing in the table, the ‘record’ is still changed correctly by any checkbox changes. So the Table is ‘seeing’ the 5 records.

I have tried exhaustive ways to get the table to load properly each time - even rebuilding it completely in a test page but same problem. I also rebuilt it with exactly the same data layout as the Rpt Group.

Other tables I have built work fine so this is a mystery.

I’ve put this up as a potential bug as I am quite familiar with the Table element but this is so intermittent. If it simply didn’t work I’d guess it was my end but this feels like a bug.

It may be that as the Table element is still in ‘beta’ mode we should only use it to test. It’s a shame as I really could do with using it.

Any help gratefully received.

It may be to do with my iMac. On my PC laptop and iPhone it works fine. There was a recent OSX upgrade so that may be it.

UPDATE: No it’s just happened on my PC laptop too. Not solved yet.

This topic was automatically closed after 14 days. New replies are no longer allowed.