Text in repeating group is different MOBILE x WEB

Hello,

I have a platform with reviews on profiles and for some reason, I’m facing different behaviors when I see the page via web x mobile.
On mobile, seems to have some blank space (image below).

But if I see the same page on the Web, looks normal.

I’m already using :trimmed at the end of the text to make sure that there are no blank spaces and the option to fit the height to the content, but it doesn’t work.

Does anyone know what is the possible solution for this?

Hi there, @EliasRamos… what do the settings look like on the Appearance and Layout tabs of the repeating group?

Best…
Mike

Hey @mikeloc, thanks for your reply. I will send the pics of the settings here.
This is the repeating group itself.


The Current cell’s review’s review:trimmer is where the problem is.

The setting of the repeating group:

The setting of the comment:

Both have the fit height to content activated since sometimes a profile may have more than one review, also is not reasonable to limit a height to the size of the comment.

What does the Appearance tab of the repeating group look like?

I fixed in 3 rows.

Right click on your element in chrome, while viewing on desktop. Select inspect, and use the responsive dropdown to select a mobile phone type. Then click inspect again in the negative space, and chrome should tell you why there is a gap there, it sort of verbosly explains if its a margin, or padding, or anything of that sort.

I would try unchecking Set fixed number of rows and changing the Min height of row setting to see if that helps.

Thanks guys, @mikeloc the problem with your approach is that I use pagination to show the reviews, if I don’t set a minimum row I will lose this point on the page ( or will create more complexity to limit 3 reviews/page).

@mattygb85 , I will inspect to see this gap.

I’ll comeback with the results… thanks again both :slight_smile:

This is will be harder than we expected.
On web is working fine even using inspect with mobile view.
(Chromme inspect)

.

Using the plugin to simulate a mobile I got the same result.

On real mobile, I now used the edge instead of the safair, but the problem still there.

@mikeloc and @mattygb85 , don’t ask me how… but I change this setting in the repeating group.

Max height to 100% and the fit height is still the same…

Now is working… I have no idea why…

On a Sunday afternoon, I’m just happy with this mystery. hahaha… thanks, guys!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.