This list is too long to be processed

Hi,

I am getting this error message instantly and I am only uploading 13 rows of data. Any idea why this is happening?

Continuing the discussion from Operation Times out:

Please pick a subcategory to help organize the information. Thanks!

Also, the more context you provide with your questions (screenshots, link to an open app, etc.), the more likely you’ll get good help quickly :slight_smile:

I have attempted to try different data types and now i get this error message:

This is the CSV file I am trying to upload.

Check the following:

  • Likely issues: Column F is hidden. You may have data in this field that is of an incompatible type. When you download/export a worksheet as CSV, hidden columns are included.
  • Is your data flat? (Ie. it looks like column E has flags on each cell. That means there is likely some behind the scenes action there. (Ie. a formula).
  • Do the data types on your worksheet match up with the data types you’re attempting to upload (ie. is column D in your database a number or a text field? If it’s a number, the “C” is likely a source for error).
  • Unlikely, but possible: Do you have a random outlier cell somewhere on the worksheet? (If so, that may be throwing off the uploader.

And if all @dan1 suggestions fail, try using Google Sheets. I have had problems with CSV files produced by Excel. I still manipulate data there since I know it so well but I always open a CSV file exported from Excel in Mac OSX Numbers of Google Sheets and resave it. Excel often includes unused columns and funny characters. If the upload does not fail it certainly can take a lot longer coming from Excel.

Very good point! I’ve noticed that Mac’s Numbers program has a habit of changing/inferring the data type of cells. (I also vaguely remember a quirk with true/false, yes/no values…).

Hi Dan,

I have been working on this for a couple of days now. I have a few questions.

So I have shown all cells - made no difference

I believe the data is flat now - no formulas anyway.

Data types - the challenge is that I have some fields that are numbers and text - How do I handle that?

Seems stupid but how do you check if you have a random outlying cell - the sheets can be quite large. Anyone know a shortcut?

Hi @patricia,

I actually have saved this file on google sheets. How do I input a google sheet into the CSV uploader?

Best,

Rachel

@rachel.camp900 under the file menu there is an option to Download as and from that menu you select CSV. Then upload as usual. If your problem is strange characters or hidden things then that will usually sort the issue. If not then reach out on the forum or do some Google searching. There are often scripts you can run on your file to see if there are any foreign characters causing problems. For example, when importing car data I hit problems on a few records that used Coúpe and a friend ran a cleaner on the file which changed it to Coupe.

@patricia - thank you. I will mull over and research some more options. What ever I do to clean the file it needs to be done by a complete novice.

If not I guess I will have to change my business structure.

@patricia

IT WORKED :slight_smile: thank you everyone!!!

Most things are not all that difficult if someone will guide you the first time you try. Knowing that Excel is a bitch for putting funny hidden characters into CSVs only comes about through bitter experience and hours of lost time. Perhaps someday you can appear all knowledgeable and suggest this fix to another novice :slight_smile:

1 Like

One day :smiley: Now onto the next struggle - displaying and manipulating the data!

This ticket has now been resolved

@dan1

Soo I broke it… had to make some changes to move forward.

I have gone through all the suggestions that were offered last time at it has not worked.

The only thing i can think of is the data fields in bubble. A couple of columns have computer IDs and serial numbers that have text and numbers and i am trying to save them in text fields. Is that right? could that be causing my problem?

@rachel.camp900 could you provide a bit more information about how it’s breaking? (Are you seeing a specific error message, is the data not appearing?) Screenshots may also be helpful. (Feel free to PM if you prefer not to post them here).

This topic was automatically closed after 70 days. New replies are no longer allowed.