Unable to connect to AWS RDS MySQL with SQL Database Connector Plugin


I’m using an AWS RDS MySQL database because eventually I need to make parts of my app HIPAA compliant. While I can access my test database through MySQL Workbench, I’m unable to connect using the Bubble SQL Database Connector plugin, although my connection string follows the protocol, as follows:

mysql://username:[email protected]:3306:db_name

I set the db instance to publicly accessible, just for starting out during dev. The error that I’m getting from SQL Database Connector is ‘Unknown database’. Yet I can connect using MySQL workbench, have been using that to set up tables.

Any insights would be much appreciated! Kind of stuck for the moment.

Thanks and best wishes,

The end of my connection string is 3306/db_name while yours is 3306:db_name

Maybe that’s the issue.

Thank you very much, joeyg, for your help. I mistyped my example in this post, did use 3306/db_name.

I have a lead I’m following up. I realized that my AWS db does not have a name, only the db instance has a name…which I used the db instance name both as part of the end point (my-db-instance), and also at the end of the connection string (3306/db_name). I haven’t found a way to modify the db name (only the db instance name) in AWS, am following up on that, then will retry the connection.

Have the solution, connected now! The db_name at the end of the connection string needs to be the schema name that I set up using MySQL workbench, within the AWS db instance.

1 Like

Thanks for posting this solution. I tried a few more options based on this. However, after trying the instance name and the schema name, still stuck.

Both result in the same error:
‘Connection issue: SQL Database Connector issue: Connection attempt failed: connect ETIMEDOUT’

Sounds like we may want to try temporarily setting it as publicly available on AWS.

@mc3digital you definitely want to make sure you can set the server as publicly availabe since you won’t have a specific origin IP address you can reliably connect from.

1 Like

I get the timeout error too. It’s a cryptic bit of documentation for getting PostgreSQL connection string. Very little helpful information and to be honest, should be much easier to set up Bubble! Host, port, username, password, endpoint fields exist in every other platform. Get to it!

Making the database public doesn’t seem to be a popular idea, it isn’t my call there. I would have tried it then watched for what IP showed up. However, I found out that it can change unless you have dedicated hosting.

Bubble support got back to me with some suggestions including whitelisting by IP range and there is a published list of ranges for the server group they are on. Still with that info we are not yet online. I wasn’t able to see what was done but am hoping to get connected next week.

1 Like

Did you also create your schema in your database? That’s the one thing I haven’t tried yet, was just connecting to the database name at the end of the connection string, so it would be something like this:
postgresql://database:[email protected]:PORT/schema

To be honest, I have no idea if it should start with “postgresql” in the connection string for my AWS RDS PostgreSQL database I created last night. If I could have used AWS Redshift I would have been happier, having used it for nearly two years, so I was hoping to settle for the next best thing. Which is why I was saying Bubble should really improve their sql connector plug-in.

I tried the schema name and database name. The IP is blocked, I have to wait on them to work on it.

Even before getting this plugin going, I am wondering about limitations. I may program in a lot of queries as well and wondering about management. For example, if you could just reorder them for grouping purposes it would be very useful coming up soon.

@mc3digital What you are saying about the public IP is true. It’s not the best idea from a security practice standpoint however it is the only way unless you move to a dedicated cluster on Bubble.

As for limitations the Pro plugin we built offer flexiblity to be able to store your queries in a table so that you can reuse them. I wouldn’t worry about limitations, I haven’t heard of anyone having a problem with limitations, more just frustration or not optimal.