Forum Academy Marketplace Showcase Pricing Features

[Updated Plugin] ChatGPT with Real-Time Streaming (No more timeouts!)

Temperature was slightly higher than normal but not extraordinary. Probably that + combination with the complex prompt…
CleanShot 2023-09-15 at 13.48.43@2x

I turned off temperature but still get nonsense words, so it is nothing to do with that. The problem is in something else

1 Like

Hm, strange. I’ll look into this shortly. I have a hypothesis about what’s going on.

On a related note, v6 is just about ready, which is a complete rebuild. It will almost certainly fix this issue.

Does it have the organization header (or custom header) support?

Yep it has both.

Just to confirm - are you setting the ID of the container using “Data Container’s ID”? This being set incorrectly is the most likely cause of that error I think.

Yes, what should it be set as?

That’s what it should be. But it can be set manually if you’re doing things like streaming the same message to multiple elements on the page.

If you’re setting it like that, using the built-in field, that shouldn’t be the issue

Yeah I don’t set the ID anywhere else.


Seems like an awesome plugin!

Question though. Is Custom instructions possible with this?
If not, maybe the possibility to always include the ‘system’ instructions so that it always falls within the maximum number of tokens?

I’m at the point to subscribe but I really want to know if this is possible. Thanks!

Hi @launchable,

I notice a bug regarding your plugin (v5.17.7): it doesn’t comply with sequential actions relying on “Trigger custom event”.

Here is a setup generating the bug:

  • ChatGPT Data Container always visible
  • Three “Trigger custom event” in the same workflow
    ** The first trigger is used for setting states (including pre written prompt)
    ** The second trigger is used to determine if the OpenAI API (through your plugin) should be called
    ** The third trigger is used to call the OpenAI API (through your plugin) if the second trigger says so.

Each time, “ChatGPT - Send message w/ server” action within the third trigger starts immediately and doesn’t wait for the second trigger. It seems to start immediately once the prompt is provided (first trigger).

Any idea?


This isn’t a directly replica of your setup but I have this which works fine:

Hi @Bobome,

It’s tough to troubleshoot a multi-step workflow like that without seeing some more details.

Can you follow up in DMs with a screenshot of your WF, similar to what George has provided in the message above? That would help with visualizing conditionals and other factors that might be playing into it.

@jfavanhoof - I think custom instructions are the ChatGPT UI equivalent of using system messages with the API. Here’s a short article on the OpenAI’s help site which says this: Chat Completions API system message vs Custom Instructions in UI | OpenAI Help Center

So you would achieve the same thing in the plugin by setting your system message to whatever you’d be setting for your Custom Instructions in the ChatGPT interface.

Hope this helps!

1 Like

@launchable hey, im seeing an error every single time using the plugin all of a sudden, Live and Dev versions; but no error when using separate plugin normal API call. I think this could be an urgent issue

It’s now worked a few times inconsistently, sometimes works, sometimes error.
Sorry I hope it’s useful to report, I didn’t know how long it would be down for.

@nathanielsmithies - thanks for letting me know. I’ll look into this now.

1 Like

Hey @launchable,

I’m facing a weird connection issue here.

When my app is streaming a long response, sometimes it loses the connection for some seconds. After reconnecting it keeps streaming, but the text that was supposed to be streamed during the connection issue is lost.

I have recorded my screen to show you this behavior.

The issue happens at 0:43 seconds.

Do you know what might be causing this issue and how I can mitigate it?

@gabriel.guilhem - Thanks for sharing this. I’ll follow up in DMs about it.

What can I do about these empty chats that people have? These are chats that are created, and either not used, or deleted. And when they’re deleted it deletes the display message and message history. Is there a way to save those in a separate database to keep them around all the time?

Does my question make sense? I’d like to keep what people say so I can better understand what users are looking for :smiley:

In your list of conversations, add a constraint that the list of display messages isn’t empty. Then users will only be able to see conversations with messages. You can also have a backend workflow that recursively scans your database every few hours for empty conversations to just keep cleaning it up.

Edit: instead of the DB cleanup recursive workflow, you can even just schedule an API workflow to run a couple of hours after a conversation is created. The API workflow simply deletes the conversation if it has no messages.

If you’re looking to keep them - why? The best option with what to do with them depends on what you’re keeping the empty records for!