User not logged in

Hi there

So basically I have the workflow when the user signs up I immediately log the user in and stay logged in, however, the user is not logged in and has to log in again, what is happening?

hi there, @enbitious… if you share some screenshots of your sign up workflow, I’m guessing someone will be able to help you figure out what’s going on. Oh, and keep in mind that when you sign a user up, they are logged in immediately as part of the sign up action. So, you don’t need to log the user in after they sign up.


Hi there, thanks for this, I think I have fixed it, however, one problem I see is this function I had is not working, seems like it is not letting me do this condition, only working for the user logged in part, not for current page width

part, do you know what is going on? Thanks very much!

I’m sure I am missing something, but in the last screenshot, isn’t it doing what you want it to do (i.e., showing the hamburger menu because the page width is less than 400)?

1 Like

Yes it is, but however, when I go to the page width of more than 400 it is not hiding and still visible.

Ah, okay. Well, the most obvious question is have you unchecked the This element is visible on page load checkbox on the element’s Layout tab?

Yep I have

Without being able to poke around under the hood, it’s hard to say what it could be. Have you tried inspecting the element with the debugger to see if you can get a clue from there?

Hey there, yes I have but it is not telling me anything on the debugger, here is the link if you want to check it out: Trendhunter | Bubble Editor

When I use the developer tools in Chrome and set the page width to less than 400, the menu shows up (it is not visible when the page width is greater than 400). So, it appears to be working unless, again, I am missing something here.

1 Like

I just checked you app, and previewed it, and the element is behaving exactly as expected…

i.e. it’s only visible when logged in and the page is less than 400px, and it’s not visible when the page is wider than that… so I’m not sure what you’re referring to when you say it’s not working…

1 Like

Thanks for this!

Yep I just checked it is working fine, idk why didn’t work before, thanks for helping me to check!

Also, I am facing this problem when I am trying to add a domain, did I make any mistake?


This topic was automatically closed after 70 days. New replies are no longer allowed.