☁️Wasabi Cloud Storage Plugin

Hi @waleed.mudassar, thanks for your patience.

We’ve updated our plugin, so it is now more adapted to the new responsive. Please update your plugin to the newest version (1.80.0: With description : Fixed responsive for conditions) and give it a try.

If there will be any other plugin-related questions or suggestions, please let us know.

Regards,
Zeroqode Support Team

When I try to retrieve files with a backend workflow, I get a response where every letter is separate by a comma:

Is this a bug or did I set it up wrong?

Hi @kreativorgan, thanks for your message.

For a better understanding of your case, please share (here or in DM) a screencast (we recommend using the Loom tool) with the whole use case flow and actions setup, as well as mention an example of uploaded& retrieved file. This will allow us to identify any possible issue much faster.

Looking forward to your reply.

Regards,
Zeroqode Support Team

Hi @tylerboodman, let us share good news.

We’ve upgraded our plugin with a new action that has followed your earlier request.

To give it a try, please upgrade your plugin to the newest version (1.81.0: Added “Wasabi - Retrieve Files” action).
If there will be any other plugin-related questions or suggestions, drop a message here :wink:

Have a nice weekend ahead!

Regards,
Zeroqode Support Team

1 Like

Hi, @ZeroqodeSupport,
I dont know if this has been mentioned or discussed in the past. I purchased your plugin, but ran into an issue.
When i upload a file (eg. Image 1) to the Wasabi Input using the “Trigger Input” action, I observed that when i try to upload another file, it doesn’t override the first file. I will now have 2 files (Image 1 & Image 2).

Lets say i now just want to only send Image 2 to the server using the “Upload” action, How can i only send one file (Last uploaded File)?
Temporarily i tried to run the action “Remove file from Input” (first Item). But this action removes everything , (instead of the first item).

Thanks In advance

Hello, @miracle. Thanks for reaching out.

Will it be convenient for you to add our support@zeroqode.com email to your app’s collaborators list? If you provide us with the instructions on how to reproduce the reported issue within your app (page name and steps to reproduce the case) - our plugin developer will be able to check it in shorter terms. At the moment we were unable to reproduce the issue by replicating your use case.

A short video recording with an explanation of how to reproduce the issue will be much appreciated (in addition to access to your app).

Regards,
Zeroqode Support Team

Hello @ZeroqodeSupport

Why is there no delete s3 file / bucket action in the backend API Workflows? It would very useful especially during recursive workflows. You don’t expect all devs to just run their workflows in the frontend, right?

Not only me but I’m sure there’s A LOT of plugin users that badly need this feature. Please implement this ASAP. Would greatly appreciate it @ZeroqodeSupport

Hello, @ntabs. Thanks for reaching out.

Let us please check it with the plugin developers team.

Regards,
Zeroqode Support Team

Hi @ZeroqodeSupport
I also run into an issue - trying to use a backend workflow to do a migration of my images database from bubble to wasabi, taking the S3 URL for the field “url_from_another_cloud” and trying it on one item of my db
Seems the URL is not recognized and the access key is required yet - there is no documentation on this issue

Any help would be highly appreciated :pray:t4:

@ntabs,

Glad to let you know that we have made a plugin update that has “Delete Files/Folders Backend” and “Delete Bucket Backend” actions. Please update your plugin to the latest 1.83.0 version and give it a try. :slightly_smiling_face:

Regards,
Zeroqode Support Team

Hello, @lauren6. Thanks for using our plugin.

Let us please check it with the plugin developer. Meanwhile, let us know if you have keys in the Upload File To Wasabi From Another Cloud Plugin field?

Plus, please, make sure you have set up the plugin correctly. As we can see, the error you get says can’t find your AWS Access Key:

Regards,
Zeroqode Support Team

@lauren6,

Let us please share the developer’s feedback on your use case. The reason for the error you receive might be:

  1. the “URL_From_Another_Cloud” field is accepting one URL per action, not a list of URLs (one file at a time);
  2. you can see the “Enter your key” notification if you have even one plugin field empty, make sure you have pasted keys in all fields

Regards,
Zeroqode Support Team

@ZeroqodeSupport - hi, the plugin works for some of my users but not all. The issue comes when retrieving files. They are all able to upload files, and the files do indeed load to Wasabi, but then they can’t see the result.

The issue is only for some of my users. Maybe there is something wrong with their browser or with their network? They tried tried different browsers so I am more inclined towards issues with the network.

The concrete question is: What should I troubleshoot when files cannot be retrieved by some users while others can? Below the logs from the succesful upload at Mountain time USA, or ~1 hour ago

Thanks

Hello, @contabilidad!
Thank you for using our plugin. :sunflower:

Could you please tell me a bit more about the problem your users have on their side? How exactly it happens?

What does it mean in the example? Are your users unable to open uploaded files on the Wasabi dashboard? Are there any error messages in the browser console from their side or error messages while opening the uploaded file? Please add as much information as possible.

Thanks!
Regards,
Zeroqode Support Team

Yes, it happens on the user side from some users only.

After they upload a file, they can’t retrieve it using the plugin. It Bubble Actions terms…
‘Upload WasabiS3 File Uploader’ - works
‘Retrieve Files WasabiS3’ - doesn’t work, or returns blank

Note again that this error occurs only for some of our users.

@contabilidad,

Thanks. Let us please try to check it on our side.

Regards,
Zeroqode Support Team

@contabilidad,

We have tried to replicate your case on our side but, unfortunately, with no luck. A few tips we can recommend to make the file, uploaded on Wasabi S3, accessible permanently:

  • make sure the file is Publick on the Wasabi side:

  • make sure you have a “NO” value both in Wasabi S3 and Upload Wasabi S3 action:

Summary

image

Hope it helps. :pray:
Zeroqode Support Team

Thanks for looking into it, but I don’t think it has anything to do with Wasabi or the plugin given that it works for most users perfectly fine. Only some of the users have the issue.

Given only some of the users have the issue, it’s more of a question of what to troubleshoot outside of Wasabi or the plugin. For example, the settings in the browser or the wifi network. What settings could prevent the plugin to work that are controlled from outside of the plugin? Examples: request delays, cookies, firewalls, etc.

@ZeroqodeSupport
This is the best explanation i can give. I can’t add collaborators due to my plan limitations.
To replicate this, do the following
1: Add the Wasabi S3 Element to a page, and set “Auto Submit” to “No”
2: Add a button to the page (Name: Upload)
3: Create an action (Trigger Input a Wasabi S3)
4. Preview the page

You will observe that when you upload an Image file, it save it in element (which is normal). When you click the upload button again, it still allows you to add another image.
Now you have Image1 and Image2 (Image 2 being the second Item)

Let say i only want to send only the last image (Image2); Based on a Users perspective, they can upload an image (Image1) and decide to change it before directly saving it in the server (Making them upload Image2).

How can i ensure that only the last item is uploaded?
I tried to run the action “Remove file from Input” (first Item), just to remove the first Item. But this action removes everything , (instead of just the first item)

Another simple solution to this is to have a way to set the plugin to choose to how many items can be stored on the element at a given time, before eventually deciding to send it to the server

I hope i made my case clear…lol…Thanks for your assistance

Hi @ZeroqodeSupport ,

I’m here reporting what I suppose is a bug.

In version 1.65.0 (which I originally used to set my app) when you use the action “Add Files to input Wasabi S3”, the selected files are being immediately added to the plugin element “Files” state so that - when you inspect it through the bubble debugger - you see :
(1) The “File count” state increased as for the number of the added file(s).
(2) The “File (Wasabi)” list immediately showing the newly added file(s).

Now, in version 1.85.0 the number (2) above is not true anymore.

As an example, if you originally selected 2 files to upload, and then use the “Add Files to input Wasabi S3” to select other 2 files to be added to the list of the files that the plugin willl upload, in the bubble debug tool you will see “File count: 4”, but you will continue to see only 2 files listed.

I have reported this in a short video here follow, where you can see “File count: 4” but only 2 files in the “File” state list.

Wasabi file list

Could you please check on your side why the File list is not immediately showing the newly added files that are instead correctly detected and reported by the “File count” state? Unfortunately, I have the file upload feature of the entire app affected by this behaviour.

Thanks,
Renato