Forum Academy Marketplace Showcase Pricing Features

☁️Wasabi Cloud Storage Plugin

Hi, thankyou for the quick response. Just to be clear I do understand how to create folders and sub folders as per the screenshot. The issue I have is if a user uploads a folder from my their computer that has subdirectories all the files from all the subdirectories end up in the parent folder, i.e. the folder structure is lost on upload. Is there a way of uploading folders with there subdirectories intact?
Many thanks
Sam

I also had one more question. Is it possible to upload files without the uploader, via a workflow. I thought you would be able to do this with the “Add Files To Input Wasabi” yet I cannot find a way to specify what files I want to add. I have used your AWS plug in and this can be achieved with the NO GUI element. Is there a way to do this with the Wasabi plug in?
Many Thanks again, Sam

Dear @bogdanevgenij & @psiccobrasil, thanks for your patience.
We have pushed a plugin update, that has fixed the above reported issues (presence of preview&name of the file, delete button).
To check changes, please upgrade your plugin to the latest version (Minor changes) and give it a try.

Unfortunately, this issue is related to the iOS in general.
Please see the link for reference (see the Safari related column):

Unfortunately, current setup is not supporting such option, sorry for the inconvenience.
Kindly note that this is due to the fact that this feature is under development globally:
https://developer.mozilla.org/en-US/docs/Web/API/HTMLInputElement/webkitdirectory

Regards,

Zeroqode Support Team

1 Like

Okay, that’s life! So it’s related to Safari, right? I’m gonna convert my app with a wrapper (nativator), maybe it will work in that way.

I have two others questions:

  1. The videos uploading by the users are most of the time formatting in .mov, however we can’t read them with video.js (videos must to be in .mp4). I saw we can rename the prefix with your plugin, do you know if we can also rename the extansion (or the entire name including the extansion)? In my case, I just have to change .mov by .mp4 and it perfectly works.

  2. The picture previews work fine but I’m facing an error message when I try to use those base64 urls with other plugins. I’ve tried with two plugins:

I don’t really understand those messages. Is there an issue with the base64 urls or is it just impossible to use those urls with other plugins?

Thanks for your answers!!

Hi @cam.from, thanks for your questions.
Allow me to add few clarifications & replies to them:

No, it is related to all browsers on iOS in general.

We will check this moment with the developer team, and see if any bugfix is required. Once it will be clear, I will notify you. Thanks for noticing it.

Speed of preview obtaining is influenced by many factors, that’s why shouldn’t transmit it elsewhere right after upload.
Please check if:

  • your workflow is working correctly
  • if the input field is not empty.
    And only then proceed to other actions. Base64 codes appear only when files are added to the input field.
    Here are the settings that we use
    image

Also, please see the link for reference: Loom | Free Screen & Video Recording Software

Hope it helps,

Regards,

1 Like

Duly noted :wink:

Nice, I hope it will be okay.

Yes, I was too impatient, now it works fine with my image cropper, thks!

Last question: I downloaded your last update (1.43.0) and the 'S3 URL option on Retrieved Files has disappeared. Is it normal or do we have to use another option to have the same result?

1.42.0 version
Capture d’écran 2021-03-30 à 17.01.59

1.43.0 version

Thks for your answers :pray:

2 Likes

THX a lot!!

1 Like

Dear @cam.from, thanks for mentioning this moment.
Allow me to check it with the developer team if a bugfix is needed.
As soon as I will have a response, I will notify you.

Regards,

Zeroqode Support Team

The recent updates have broken some functionality that previously worked in my app. Am using the filter filenames feature and am autosubmitting files that are selected. Console error below along with a screenshot of my settings. Would love to get this addressed. Rolling back to version 1.36.3 fixes the issues, but this doesn’t feel like a good long term solution.


Dear @cam.from, thanks for your patience.
We have pushed a small plugin update, that has fixed the reported issue.
To check changes, please upgrade your plugin to the latest version (Returned missing fields from retrieve file) and give it a try.

Dear @andrew10, thanks for reporting this issue.
Allow me to check with the developer team if a bugfix is needed.
As soon as I will have a response, I will notify you.

Regards,

Zeroqode Support Team

Done and indeed the 'S3 URL option on Retrieved Files is back, however it doesn’t work… it looks like it doesn’t retrieve any files.

I get back to the 1.42 version.

Tell me if you need more info :wink:

Best

HI @ZeroqodeSupport

I must say Im finding this plugin I purchased quite frustration :hot_face: .

When I save an uploaded file it alway saves with a empty text . please see screen shot below.

Also where do I find this ‘‘foreach’’ as on your demo?

Screenshot 2021-04-06 095953

If foreach is a paid plugin? how do I achieve the same outcome without having to use a paid plugin.

and finally

Im trying to upload a single video file to my wasabi account.

Im using a plugin called Cam Capture which automatically saves a video file to my apps file storage when its finished recording. I need this to be saved to wasabi. (Its why I bought the plugin )

Is there a way with this plugin to upload that cam capture file which has been saved to my file manager in my bubble app, and automatically upload it to my wasabi storage ?

Any help appreciated

Kind regards

Tim Garrett

Dear @cam.from & @timgarrett111, sorry for the same words, need to check it with the developer team to identify the reported issues. As soon as I will have a response, I will notify you.

It stands for the element of the additionally installed Ultimate Toolkit free plugin, that helps to record many elements in the database at once (because Bubble platform has a limitation in this regard).

Allow us to check if such an option is supported. We will come back with a reply in a due course

Regards,

Zeroqode Support Team

2 Likes

Just wanted to check in on this. Any updates?

1 Like

I’ve another issues/questions for the developer team :slight_smile:

  • 1/ DELETE BUCKET / Issue with dynamic data

When I want to delete a bucket, I’m using this with a dynamic data to delete the targeted bucket (which has the name of my recipient id), however the field appears as empty when I run my application:
Capture d’écran 2021-04-07 à 09.57.12


Capture d’écran 2021-04-07 à 09.24.50

I confirm my dynamic search works (I’m using the same query when I want to add files to my bucket and it perfectly works).
Capture d’écran 2021-04-07 à 10.03.12

However, when I type manually my recipient id, the workflow works and my bucket is deleted (IF my bucket has no files, see my next point).
Capture d’écran 2021-04-07 à 09.26.00

My guess: dynamic data is not working on this action.

  • 2/ DELETE BUCKET / Not working when the bucket has files

I need to delete buckets with all their files and according to your documentation, I can do that with a Delete Bucket action:
Capture d’écran 2021-04-06 à 17.06.01

However, when I do that (by adding my bucket name manually :wink:) it doesn’t work and tell me it’s not possible.

Here is the Wasabi view of bucket I want to delete (with one file):

Here is my query on bubble (adding manually my bucket name and not dynamically):
Capture d’écran 2021-04-07 à 10.17.34

And here is the result when I run my workflow (I don’t know why the message is in French, but it says ‘the bucket is not empty, so it cannot be deleted’ and indeed, my bucket hasn’t been deleted):
Capture d’écran 2021-04-07 à 10.19.01

My guess: there’s a new restriction on Delete Bucket action when the bucket has files :roll_eyes:

Tell me if you need more info!

Thks @ZeroqodeSupport :pray: :pray:

Hi @andrew10, I’m afraid we cannot provide time estimates on this matter. Once we will update the plugin, we will notify starting with this forum thread.

Hi @cam.from, thanks for the question. Allow us to analyze them and come back with a reply in following days.

Thank you for understanding.

Regards,

Zeroqode Support Team

Greetings, @Appkit and @ZeroqodeSupport. I’m considering purchasing this plugin (and investing in Wasabi as my cloud storage platform thanks to your providing this plugin).

Before I do, though, I want to be sure it/Wasabi can meet my needs. I’ve tried to test it out by viewing the Plugin Demo editor, but the read-only restriction prevents me from testing what I need to test. :frowning: I’m also not very familiar with APIs/SDKs, so I’m hoping your plugin will spare me some pain and suffering and help me maintain the Bubble “no-code” experience. :wink:

Here’s the use-case: I am creating an e-learning platform that will host videos in Wasabi and let users who purchase access on my Bubble app view that content for a specified time period. After X number of days, they will no longer have access. Here are my questions:

  1. Does your plugin support fetching only certain files that have already been uploaded to Wasabi, meaning using some kind of Bubble criteria (filter?) to ensure only certain items display?
  2. Does your plugin’s use of the AWS SDK include the option to generate pre-signed, expiring view-only URLs (see the temporary, automated access section in this Wasabi documentation link)?

Is this something y’all can help with?

Dear @eLPDev, allow us to analyze your inquires and come back with a reply in due course.
Thank you for understanding.

Regards,

Zeroqode Support Team

@ZeroqodeSupport , thanks so much for looking into that for me.

1 Like