🛠 ᴺᴱᵂ ᴾᴸᵁᴳᴵᴺ Wasabi Storage Dropzone & Utilities (Image Resize & Compression, MultiUploader, Folder support & No Filesize Limit!)

Is there way to access file’s metadata?

Yes. The Dropzone element exposes each file’s metadata.

Alternatively a backend action is available to retrieve a stored file’s metadata as well.

1 Like

folder

Is there a way to split this into two options?
1st option would be “Enable Folder Upload” (behaves like yesterdays version)
2nd option would be “Retain Folder Structure” (behaves like todays version)

That way it can still be like the version from yesterday where you can drop in a folder and it just uploads everything into one folder instead of replicating the structure?

It should currently behave as you described.

I uploaded a folder from Windows named level 1, with a folder in that called level 2, with the pdf in that,

Then when I upload in the workflow I first create a thing, and add that in front of the upload path (so every file is in it’s own subfolder):
Screenshot_3

But it’s keeping the level 1/level 2/file10.pdf in the upload name so it’s showing in Wasabi it created level 1/level 2 as folders:

What I would expect if the “retain folder structure” can be turned off is it just uploads “file10.pdf” under the first folder “1661890054443x390713387688919000”

I’m assuming it’s uploading all those folders because the “level1/level2/” is in the name and Wasabi interprets that has “make a folder”?

Is that how it handled it yesterday maybe I didn’t notice?

I can’t reproduce the issue on my system. I tried with level1/level2/file to make sure.
Do you have a UNIX system/different browser at hand to try out? I suspect a platform-related bug.

Okay tried it on Win10 Chrome, Win10 Edge ,Ubuntu 22 Firefox and all do the same thing.

Interesting but I can drag a folder right into the Dropzone and it uploads like I was showing earlier.

But If I click on the drop zone to browse files, on Windows and Ubuntu it wants me to browse to a specific file it doesn’t want to upload a folder

But If I select a folder + a file it will upload all of it with the structure problem still… I just tried that on Ubuntu.

Maybe this is intended behavior? Idk :laughing:

Would you mind to DM me a loom/screencast of the issue with the settings along with demo page, ideally with editor access?

Just to make sure. The “Retain folder structure” option must be unchecked to upload all files and folders without retaining their structure.

Yea that would make sense. It’s almost like it could be 3 separate options:
“Upload Multiple Files” allows selecting multiple files
“Enable Folder Upload” allows selection of folders
“Retain Folder Structure” would do what it’s doing now but for my case I would uncheck it so it will search all folders but only upload the files with their names. (no level1/level2/)

In the latest version only those are implemented:

Oops sorry I was on 1.4.0 my editor didn’t show a new version until I refreshed just now. I’ll try the 1.4.2 right now.

Looks good thank you so much. I’ll compile my remaining ideas and check with you if they are possible. Right now I think what’s left is:

  • Rename files (technically would this enable a move function as well since you could rename it with a new path?)
  • Upload as a “public” file so it can have a direct URL
1 Like

I know you said it’s not possible but keep it on your suggestion list please, I just timed it, it took 10 seconds after dragging in a 1MB PDF for it to initialize the upload before it could start uploading. It was quick from that point on but when changing pages it always takes a long time. :grimacing:

Also here’s another one:

Is it possible for this action to have a field to specify a path? So it could retrieve all the URL’s inside a subfolder instead of bucket wide? In this case I’m looking at it in the backend.

Done.

1 Like

Copy action has been implemented. Renaming is therefore available by the combination of Copy then Delete action.

1 Like

Sweet I’ll try it out. Is there something in place so the copy starts, then the delete won’t start until the copy is done? You know how Bubble doesn’t really do things one step at a time…

If the Copy action does not return the file path / URL, then it failed. You may use it as a test for the next action.

1 Like

Yep looks good :+1:

On the “Copy file” action it seems like it’s missing the “Target Bucket Region” field but it allows a different Bucket name.

Also on upload I store the result’s UUID in my database, when copying/deleting is the new file’s UUID different? Is the UUID even needed when I store it?