Way to code a line break into RTE?

Hi. I’d like to move all our “send email” actions to the API workflows. I also want to keep the formatting.

So, I’m scheduling a workflow (on page) that will then hit an endpoint with a “send email” action (in API workflows).

The schedule a workflow looks like:
image

The send email action looks like:

I’m looking for a way to add a line break in body when it’s sent as a schedule a workflow. I’ve tried
; /r ; /r/n. All these are printed as text instead of a line break.

image

Any idea if it’s possible to add a line break as code?

1 Like

Are you using the email send default by bubble? (Though you were using another)

I am. I want to send the entire body as a input to the API workflows though.

From this SO, it appears there needs to be a config setting to permit it.

Ah, I think I’ve answered my own question and the answer is ‘no’

When a text string is passed to the API workflows, if there are “\r” or “\n” in the string, these get escaped.

p1 \n p2 \n p3 becomes p1 \n1 p2 \n2 p3. I can see the escape \n in the logs when I send \n through the scheduler.

Exactly that’s why I tough you were not using the default bubble send :stuck_out_tongue_winking_eye:

PS. If you want update and send some cool mails using templates and html tags in body check: ✉ Sendinblue SMTP A free alternative to Sendgrid mails by Reduble.com

Regards :+1:

Thanks. The issue is not the send email itself but a database permission setting that all our emails need to go out through the API workflows.

1 Like