Forum Academy Marketplace Showcase Pricing Features

What are the limitations of doing a search?

I"m running into a weird issue, and I think its due to the fact that I’m trying to search for a thing’s thing.

Instead of two types of users I created users (users) and businesses (things).

In an attempt to enable conversations between users and businesses I created another thing called a “participant”, which allows me to create conversations between participants regardless of whether the participant is assigned to a user or business.

When creating a new conversation, the following workflow works the first time a participant is clicked. However, it displays the wrong user in the chat when the conversation already exists. This leads me to believe this search is too complex.

Do I need to go back to my db and just create a user_type field on the user?

I was trying to avoid multiple sign-ins for a user who also has a business.

Edit: It seems this issue only occurs in the Native app previewer. Its fine in my browser.

@emmanuel, any chance I can get you to take a look at this? Thanks in advance.

There isn’t such a concept of a too-complex search. If the interface lets you do it, that’s something we support. Now the question is ‘are you constraints right’? Have you tried in the debugger?

If it’s fine in the browser but not in the native, that’s likely a bug, but I can’t guarantee a fix, since we’re in early beta there.

Okay good to hear. Hopefully its an issue on my end. I’ll go back over everything. Thank you.

So after review, this issue only occurs when my repeating group of conversations is sorted within the “Do a Search”. When appended with :sorted it appears to be solved. Not sure if this is a bug. But figure I would post my findings anyway.

Well if the sort at the search level doesn’t work it’s a bug. Please file a bug report then.

1 Like