Why is Bubble changing my text?

I’m adding simple email notifications for activity on my app, and I’m adding links to go view the activity. These links have a project and a notification as parameters in the URL so that the page knows what data to take them to. Here’s what I have for the body of the email, including the parameters:

image

Notice the part I highlighted. Now look at the URL it actually takes you to:

https://home-url/projects-all?project=1640119645605x150246748683239420¬ification=1661569032323x681444685386088400

Why is it adding that character in place of “not”, and how do I stop that from happening?

I noticed that in the actual email that’s sent, the link is some intermediary SendGrid link, I’m not sure why. Would be great to just have the actual URL that I’m specifying in the email.

Any ideas on how to work around this, aside from excluding the letters “not” from the URL? I’d hate to have to go through and find everywhere I’ve gotten data from the URL and manually update.

Thanks for your help!

Hello @johndurso

In a prior step try setting that url to be ready and then use it in this step. It is a worth a try.

Another idea would be to use :urlencoded … but I do not see the need for it as you have it well structured.

All I can think of why this is happening is that the html is being changed when it reaches the email client. I have heard that html-email is tricky.

I realized that is wasn’t just adding that character in place of “not” but in place of “&not”. So as a workaround I just switched the order of the parameters in the url to make notification first, with no ampersand before it. This is working for me now. Weird though.

@cmarchan I don’t think gmail (my email client) is changing it because the link in the actual email is a SendGrid URL that then redirects to my URL. Do you know why Bubble uses that as a go-between? It seems to be messing with some other workflows on the page that happen on pageload.

That body box is not from a Bubble send email action?

It’s from the standard Bubble send email action, no plugin or anything else. That’s why I’m surprised that the link in the email, when I hover over it in gmail, shows a SendGrid link.

Just to check…

Try to change the word “notifications” for the word “test”…. I think some HTML replacement behavior can be happening…

1 Like

Yes I think that’s it, as I mentioned above when I put notification as the first parameter, meaning there isn’t an ‘&’ before it, everything is fine. It’s when “&not” appears that it gets replaced.

This topic was automatically closed after 70 days. New replies are no longer allowed.