Workflow "Result of" error

Hello,

I have a problem with a workflow.

I have two data types Type 1 and Type 2. In Type 1 there are two fields of Type 2: let’s call them Type2.1 and Type2.2.

In my form, I want to:

  1. create a Type 1 thing
  2. create two Type 2 things
  3. assign the two newly created Type 2 things to the two fields of the newly created Type 1 thing

all in one go.

So, I have a Workflow that includes the following actions:

  1. Create a Type 1 thing
  2. Create a Type 2 thing
  3. Create a Type 2 thing
  4. Set Result of Step 1’s Type2.1 to result of Step 2
  5. Set Result of Step 1’s Type2.2 to result of Step 3

Steps 1-3 work as expected, all things are created successfully.
Steps 4 & 5 do not work.

I do have conditions on the steps but they are all met (I checked through debug_mode, but to make sure, I removed them altogether and tested again anyway).

Could it be that newly created things can’t reference one another yet in the Workflow? Although I have already read that using the “result of step…” means that the action using it explicitly waits for the action where the thing is created to complete before triggering.

Any ideas on what to check next?

Is the user able to see the created data through privacy rules? If not they might not be able to add it in the next workflow step. (not sure about this)

Have you tried checking the server logs?

You can try a workflow like this:

  1. Create a thing Type 1
  2. Create a thing Type 2.1
  3. Create a thing Type 2.2
  4. Make changes to a thing (thing to change: resault of the step 1), and set which parametars to change (field for type 2.1 = resault of step 2, field for type 2.2 = resault of step 3)

It should definetly work like that

Hi - thank you for your response.

I don’t have Privacy rules set on these data types.
Server logs are empty.

Hi - thanks for your answer.

This is what I am doing, if you read my post. No 4 doesn’t work.

What do you mean it’s empty? You have no server logs?

Something you’re telling us isn’t adding up.

Using debug mode, what do steps 4 and 5 show (other than that they ran)? Does it show that the correct result of previous workflow was assigned to the correct Thing?

1 Like

OK, I am sorry I wasted your time.

Still, it wasn’t all in vain, as I made good use of the logs for the first time. They were empty because I had not indicated the correct time period. I ran it again and checked them.

I thought the workflows ran as expected because I wasn’t missing an action - there was one extra running.

Clicking from the log to the workflow, back and forth, really helped me catch the culprit which was a small leftover

image

Again, I am sorry about this - but, at the end of the day it was your help that fixed it. So thank you!

1 Like

This topic was automatically closed after 70 days. New replies are no longer allowed.