Forum Academy Marketplace Showcase Pricing Features

Zapier not finding referred data

I’m building an employer ratingapp. I have it set up so that users can rate their employer on my Bubble site but now I want to use TextIt to allow users to rate their employer using a textbot as well. I want the results of the textbot ratings to go into my Bubble database so I’m using Zapier to put the information from the textbot ratings into my Bubble database. The set up works fine except for company name.

I have 2 data types: Company and Rating. Company Name is a field within Company and this field is referred to in Rating. When I try to set up the Zap, I keep getting an error saying:

Invalid data for field Company Name: object with this id does not exist

  • I’ve checked that a Company with the Company Name I’m using does exist.
  • I’ve tried having one Zap that does 2 actions in Bubble i.e. it creates the Company with Company Name then tries to create the Rating with Company Name but I get the same error.
  • The same thing happens if I make try to do this as two separate Zaps (although the Company with Company Name is successfully created).
  • I have even tried doing a Zap with 2 actions where I search for the Company first, then try to create the Rating. I get the same error.

Is it not possible to write to fields in Bubble if the field is a reference from another data type? When a user adds a rating the normal way i.e. on Bubble, there must be a Company with that Company Name first. But in this case there is a Company with that Company Name and Zapier seem incapable of seeing that within the Create Rating step. Can anyone think of a workaround? Please!

Bump :upside_down_face: