Forum Academy Marketplace Showcase Pricing Features

ZQ Fuzzy Search Multiple Input Issue

Hey guys (or @ZeroqodeSupport),

Does the fuzzy search plugin not work when there are multiple inputs on the one page?

I had it working fine with one input, one fuzzy search and one repeating group. But I need to have 4 on the one page. Should that be possible?

Hello, @nickhutton13
Thanks for your request.

Yes, we confirm that it works.

Please note that in case you are willing to create multiple inputs on your page, you should place a plugin element for each input on the page.
So, the single plugin element “Search and Autocorrect” can’t work with two or more inputs.
Do not forget to provide the unique ID for each of them. :slightly_smiling_face:

Please try it and let us know about the result.
Best regards,

Thanks for getting back to me @ZeroqodeSupport !

I’m not sure if there’s a bug or something then? Because I’ve set up 4 inputs, 4 search and autocorrects, and 4 repeating groups. I’ve matched the IDs but when I search, it comes up with absolutely nothing.

Hello, @nickhutton13
Sorry to hear that.

Please check that the DataSource of your repeating group is set correctly.
Additionally, please provide us the screenshots with the current settings for one of the groups (plugin element, input, and repeating group) for our investigation.
We need to check all of them to find an exact issue :pray:

Looking to hear you soon.
Best regards,
Zeroqode Support Team

Sorry for my delay @ZeroqodeSupport, but I sorted it out. I needed the ‘Ignore Empty Constraints’ field ticked and I didn’t have it.

1 Like

Hello, @nickhutton13
Thanks for this feedback.

We are happy to hear that it is working now on your side.
In case of any additional questions - you are always welcome! :slightly_smiling_face:

Best regards,
Zeroqode Support Team

1 Like