Allow Brazilian Currency (R$ - Reais)

Dear Bubble Staff,

Please allow us to set the currency default inputs in Brazilian Reais, it goes like this:

R$1.000,00 (for example).

In my app, I always have to add an “R” and then the formula to get the currency.

Hope my idea is implemented.

Best Regards.


R is possible as a currency format. (See GIF below for how to set it up - can be set up on inputs or formatting text values).

Though is it that you’re looking to also include the “$” as part of the currency value?


Hello Renato, why do you need to set it as default currency? In every situation I met I could just format it so it looks the way I need it to look.

Olá Renato, por que você precisa de colocar Reais como padrão? Em todo caso que eu precisei, pude fazer os números ficarem na aparência que eu queria e isso resolve sempre.

I also get around it like @vini_brito does, but I wouldn’t mind the almighty BRL becoming a first class citizen in the platform. :money_mouth_face:

Yea, I’m also doing it like @vini_brito, always inserting an “R” before the formula for the currency value “$00.00”, so it looks like “R$00.00”.
However, it’s something we have to set up every single time when using values, and when its an autobound input it just stays as “$00.00” as there’s no way to set the “R” there. It would be very useful if we had the option to use “R$” as currency.

I believe it would be something simple for Bubble to add, it would make the job easier for us in Brazil, and improve our user experience.

The “R00.00” setup @dan1 has proposed is the default for south african Rand, not Brazilian Reais.

Thank you very much for the feedback. Looking forward to hear from Bubble staff.

Best regards.

1 Like

@renatoasse thanks for the detailed response. Appreciate you letting me know the difference between the Rand and Reais.

Inspired me to dig a bit further and I came across this table of the most common currencies, along with the ISO 4217 symbols.

Just an update here, I questioned Neerja about this and here’s the response:

Thanks for reaching out. You can customize further by deleting the ‘Currency Prefix’ input and pasting the symbol of your choice. Let us know if you run into any issues.

Well, seems kinda stupid, but I didn’t know I could just delete the prefix and type the one I wanted:

It completely solved the problem.
Thanks Neerja and Bubble staff.