API call issue - "message": "you must provide a model parameter"


I am new to bubble. I am trying to make some API calls to OpenAI but with no luck.

Here is the error message:
There was an issue setting up your call.

Raw response for the API
Status code 400
“error”: {
“message”: “you must provide a model parameter”,
“type”: “invalid_request_error”,
“param”: null,
“code”: null

And here is the parameters I include

maybe try refreshing your browser tab and attempt to initialize again…sometimes the API connector is a bit finicky…looks like you already have the model parameter added with a value.

If it doesn’t work after refreshing the tab, double check and ensure your model value is an actual model

Thank you, I tried both your suggestions but… nothing… always the same error…

Try to add header content-type with value application/json

1 Like

Here is the call I’ve implemented from the openai docs

This is the editor link, take a look at the plugins tab and see the details of the call.

try replacing the model value parameter from what you have currently to gpt-3.5-turbo and if it does, that would indicate the model value you currently have might not be an actual model

Yes it’s with value “application/json”…

Nothing is changing… always the same error

Tried but nothing… always the same error

Could it be because I have the free version of Bubbble?

Not likely. As long as you have API connector installed, you should be able to make API calls on free plan.