API Error - The API call returns a non-object and you picked JSON

Hey, having some issues with API Connector.

I’m calling an endpoint that returns JSON and I think my setup is correct, although I have tried various variations with no luck. If I initialise to page 1 of the endpoint it works, page 2, 3 do not work and then page 4 works. It’s all the same content so not sure how this could be happening?

Have tried a few different headers but had no luck with any combination so far.

Tried in postman and each page returns JSON just fine as expected. Really stuck on this one?

What does Bubble return when you change the Data type to “text”?

Check the screenshot below and see that Bubble returns whatever it got back, unformatted.

End points from here.

When changed to text it just returns what’s expected in what looks like JSON. Its also in the exact format as page one which is why its so baffling.

Are pages 1 and 4 consistently working and pages 2 and 3 consistently not working?

If you check “Capture response headers”, do you see this (application/json) on each of the pages?

Yes 1 and 4 always work while 2 and 3 don’t.

Just done that and this is what it shows:

Edit: @julian5 sorry just realised I uploaded the wrong screenshot by mistake. Fixed that now.

You might want to report this to Bubble with screen shots for each of the pages (1, 2, 3, 4).

If the content-type in the header of the response is application/json, and the content is correctly formatted JSON, I’m not sure why Bubble wouldn’t be picking it up, especially if postman is. I assume Postman is correctly detecting the content-type and formatting it.