API not showing up on external API list

I am currently facing an issue, in which one of my external APIs is not showing up when I try to use dynamic input.

I have two API calls set up on the API through Bubbles API connector, and one of the two calls shows up perfectly fine. I added the new call today, have it set up the same exact way as the other one. When I initialize, it gives me all of the outputs that I need. I am not sure what I am doing wrong. Any help would be greatly appreciated!

Yes, I am aware that there is another topic very similar to what I am facing. The solution on that post did not seem to work for me.

If you care to share a screenshot of your API connector setup I’m sure someone here can help.

Will do, give me a a minute to get that for you.

Where are you trying to access the API calls (i.e. where is the other one showing up but this one isn’t?).

I am trying to use dynamic data to get text. I am doing this through “get data from external api” in which the API I want is not showing up. Hope that makes sense.

In that case it certainly looks like everything is set up correctly (if it’s set as a data call and has been initialized then it should be accessible from within your pages) , so without more info I can’t see what the issue is.

If you want to to share a link to your editor I can take a closer look for you (perhaps tomorrow), as I can’t see any reason based on the screenshot or info you’ve shared as to why it shouldn’t be working.

I am going to try deleting the API and setting it up again with a fresh code. If that does not work I will send you the editor tomorrow.

1 Like

Not sure why it worked, but I deleted the API and re-entered it with a fresh key. Worked just fine. Thank you for your help!

1 Like

@adamhholmes and @mikegmathisen I have this same problem. I set up the API data but it does not show up in the get api list . I’d appreciate your help


image

You need to initialize the call first…

Okay @adamhholmes Thank you very much. Now showing.

1 Like

I"m having the same issue. I’ve initialized, reinitialized and I’ve deleted the API Call and Recreated it as well as Created another one, but it will not show up. Please help!

Same issue!

Just added a couple Stripe API calls via the API Connector, but they’re not showing up when I attempt to use them as a Workflow action from the Plugins menu. All 4 calls I’ve added via the API Connector have been successfully initialized.

The 4 calls I have set up in the API Connector:
image

But only 2 of the calls show up as options to use from the action menu:
image

Has anyone found a solution to this?

Are they ‘Action’ calls?

2 Likes

Just realized that after posting - that was my issue. Thanks!

For anyone else experiencing a similar issue, check the “Use as” field on the API calls that aren’t showing. Setting to “Action” makes them available.

1 Like