Forum Academy Marketplace Showcase Pricing Features

API Set up working in Postman, but not in Bubble - Content-Type "application/x-www-form-urlencoded"

I have an API call that I got working in postman but I am struggling to make it work in bubble.
The error message references “401 - Unauthorized: Access is denied due to invalid credentials.” But I have confirmed from the API provider that this call successfully passed through their authentication process. They would have thought the issue might come from the first parameter (insertPartyID), but you can see it is the same as in Postman.

I solved my own problem. It appears the API call needed to be ofContent-Type “application/x-www-form-urlencoded”. I could initialize the call, but it required me not using the ‘parameter’ area and scripting the call in the Body section (see image below). I also added a “Content-Type” key in the header.


Hi, I have the same error. My problem is that, apparently, I HAVE to use the params area, since in the API that I am connecting (Food Request Step 1 - Parser, docs here Edamam - Eat better!), everything goes as a query params, including the authorization key.

So if bubble do not allows initializing APIs using the params area, this API couldn’t be connected?

Anyone have any ideas on how to solve this?