API Token Request 401 Error in Bubble but works on Postman

If anyone could help me out here with would be much appreciated.

I have an API call to request an auth token, the call works fine in postman but I continue to get a 401 error in bubble. I’ve seem to try all possible solutions and am just stuck at this point.


If anyone could shine some light here I would be overly grateful, thanks!

Your json body is formatted wrong.

Remove brackets
Remove quotation marks
Remove new lines and spaces

grant_type=<client_credentials>&client_id=<client_id>&client_secret=<client_secret>

Still not working :frowning:

Can you send an updated screen shot and error message?

Hey, make sure you are using correct content-type and add link to the api docs if you will need any additional help.

Im using the content type required by the “docs” and I use quotes because they don’t have proper documentation for token access. Only a pdf with a curl method. See below

have you actually supplied the client identifier or are you trying to initialize blank?

grant_type=client_credentials&client_id=<client_id>&client_secret=<client_secret>

1 Like

Got it! I had the keys in there yes but had forgotten you said to remove the brackets.
So after removing the brackets it worked. Thank you!

1 Like