Autofocus Input Do NOT Do

I have an multiline input element in a popup. When that popup is displayed the multiline input is automatically getting focused. I do not have a workflow event set to do this, and do not see any workflow event to make it so the multiline input is not automatically focused, nor do I see any checkbox options on the multiline input element in the editor to mark it to not be automatically focused.

Auto Focus Input

Is this some new ‘feature’ they added? If so, it should be more complete and allow us to turn it off…not every input is required, and is optional, so an autofocus is bad UX

I do not have this multiline input marked as necessary

@eve is this a bug, or some new expected behavior? If it is expected behavior, how do I turn it off?


For better or for worse, Bubble seems to automatically give focus to what it determines to be the “first” input available. In my experience, simply rearranging inputs will cause the auto-focused one to change.

If the aim is to not have anything appear to have focus when the popup appears, one [janky] work-around would be to add an input (such as a checkbox) at the top of the popup (and not nested in a group or anything) and then cover it up with a “bandaid” (such as a Shape element) whose color matches the background of the popup.

Please remove Backshadow style from the conditions of input.

To elaborate… What @vinaytadahal is saying is to simply remove the conditionals which change the border appearance when it has focus. To do that, you have to remove the assigned style, and then the conditionals can be edited.

Technically, however, the input will still have focus; it will just be less obvious. So I guess it depends on whether the desired UX is related purely to aesthetics or if there’s a functional consideration as well.

I think the best work around is what you mentioned previously about the ‘bandaid’ fix until bubble makes the checkbox of autofocus or some other better system to avoid this.

My UX requires the box shadow for when the element is focused as you rightly pointed out.

1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.