Forum Documentation Showcase Pricing Learn more

☁️ AWS File Uploader No File Size Limit- New Plugin from Zeroqode

Hi Kris, you can do this in Bubble database, when you upload a file into AWS also save the link in the Bubble database and assign some category to it, and then you can manage these files as you like.
makes sense?

Yes, it makes sense, but should I use “when fileuploader A uploading is finished” action for this?

Yes, that’s right


Hmm @levon . I cant seem to find a workflow that deletes the S3 items. I can delete what I have stored in Bubble ofc, but I cant seem to bring the most logic actions to the surface… I have seen your editor of the plugin, but I want to use an icon in a repeating group listed uploaded files to delete.

Edit: I finally found the “delete item” under the plugin actions. However, I cant find a logical way to delete the apropriate bubble record when I delete a file from S3. Any hints?

Hi Kris,
you have to use 2 workflow actions, one to delete the file from AWS, and one to delete from Bubble.
you can match the records by the link (if you store the link in your Bubble database)

Thanks @levon! That cleared it up :slight_smile: Thanks!

Hey @levon

The plugin seems to be working great accept the files aren’t automatically public for our users. We have to manually make each file public in order for them to be visible to users. Any idea on how to solve these? The error we are getting is below.


This XML file does not appear to have any style information associated with it. The document tree is shown below.

<Message>Access Denied</Message>
1 Like

Hey Daniel,
where do you see this error?
how are you making each file public manually?
did you set up the CORS settings correctly as we have explained in the docs?

When a file is saved in Bubble (in a file field within a table), I’m able to get the link. I click on that link and I’m taken to another tab where it says the error previously mentioned.

Then when I go to the Bucket, find the file, and manually make it public, the link now works.

Yes, the CORS settings seems to be set up perfectly. We’ve narrowed down the problem to the file not being public immediately.

If you have any ideas on why this is happening, that would be great! Also, I can provide specific screenshots if needed.


Hi Daniel,
it looks like an issue with bucket’s properties.
I would either suggest you to re-create the bucket from scratch and follow our instructions exactly as they are (you should make the bucket public when creating it)
or try to click on your bucket and then go to “permissions” and then check what’s under “Public access”
(See screenshot)
also this doc might be handy

1 Like

Cheers, I’ll get back to you soon with the results.

Solved the problem. Cheers!

1 Like

hi @levon, it would be great if:

  1. we can select an option that if the image is smaller in pixels or in kb than the resize parameters, don’t resize it.

  2. Also, that we can change the text of the crop buttons (to put them in spanish), and to create personalized messages to the user when the image is too big, or not allowed, etc.

  3. when you crop an image, the resize don’t works well.
    For example if you upload an image of 5 megapixels, it resize it to 500 kb, but when you crop it, the resize will be 1,2 mb .

  4. when you attach an image from an cellphone, the thumbnail
    makes a turn counterclockwise.

Thank you !

Hi, @dbevan, I’m having the same problem, how do you solved it?


I actually don’t know. The client I was working with did the process over again and it worked. Not much help sorry.

ok thanks

we have pushed an update to the plugin with the following improvements:

  1. added checkbox that (allowing/not allowing) cropping the image if the cropped size is smaller than “image resize height” or “image resize width”
  2. added fields for crop modal title, crop modal save button and crop modal cancel button.
  3. if uncheck “image processing” checkbox, will work fine.

we couldn’t reproduce this

I have a couple of problems. ( I use v1.7.0 since the last one throws error, see below)

  1. my portrait photos rotate 90 degrees. I guess the plugin ignores the exif orientation data.

  2. the “inspect” button for debugging simply disappears when I use the uploader.

  3. As a preview, I use my own repeating list by getting “File Uploader’s List of URLs” after “Upload is finished” event. But if I upload images one by one, it takese too long to render. Repeating list appears but image just shows really late. What could be the cause?

I get this error at the last version::

VM1288:3 Uncaught ReferenceError: $jscomp is not defined at eval (eval at h.create_code (x5:15), <anonymous>:3:23)

(anonymous) @ VM1288:3
setTimeout (async)
(anonymous) @ VM1288:3
(anonymous) @ x5:15
I @ x5:15
(anonymous) @ x5:15
Ce.run_without_catching_not_ready @ x5:15
(anonymous) @ x5:15
e._run_if_not_destroying @ x5:15
e.run_me @ x5:15
e @ x5:15
Ce.autorun @ x5:15
e.autorun @ x5:15
(anonymous) @ x5:15
e.wait_for_visible_lite @ x5:15
r.initialize @ x5:15
c.initialize @ x5:15
(anonymous) @ x5:15
Ce.autorun_top @ x5:15
e.initialize @ x5:15
e.draw @ x5:15
e.draw_children @ x5:15
e.draw @ x5:15
e.draw_children @ x5:15
e.draw @ x5:15
e.draw_children @ x5:15
e.draw @ x5:15
t.display @ x5:15
d @ x5:15
(anonymous) @ x5:15
t.notify @ x5:15
e._was_updated @ x5:15
t._dec @ x5:15
t.notify @ x5:15
e._was_updated @ x5:15
t.turn @ x5:15
(anonymous) @ x5:15
j @ x5:8
k @ x5:8
setTimeout (async)
(anonymous) @ x5:8
i @ x5:8
fireWith @ x5:8
fire @ x5:8
i @ x5:8
fireWith @ x5:8
ready @ x5:8
R @ x5:9


we couldn’t reproduce this issue, it works fine, can you retry?


this question is more of Bubble related performance issues, so I’d suggest you reaching out to Bubble support for this.

we don’t see this

we suggest you to remove the plugin and all its elements from the app, then install the newest plugin version and retry.

Levon Terteryan

Founder @ Zeroqode


Bubble Templates

Bubble Plugins

Bubble Courses

Convert Web to iOS & Android

No-code Development Services