Forum Academy Marketplace Showcase Pricing Features

Body parameters not available as action workflow

Hey! I am new to Bubble and I tried to find a solution to my problem on this forum, but I couldn’t find it, so that’s why I am making a new topic for it

I made a new API call with the API connector plugin, because the type of call I wanted to make for Stripe wasn’t available on another plugin. I am doing a POST request as you can see here:

I initialized the call and that seems to have gone about right. I got a response and saved it.
However, the dynamic body parameters that I specify are not available for editing in the action workflow, as you can see here:

Did I forget to do something? Or did I find a bug? I tried to refresh the page, logging out and restarting my browser, but I keep seeing the same. I cannot put custom body parameters in the workflow menu. :grimacing:

Help is very much appreciated!

If you untick the “Private” box, they should appear in the workflow editor :slight_smile:

1 Like

Thanks!! That was it :smiley: Do you also know maybe what is the use of the ‘private’ checkboxes?

Good question! I think it relates to security, this link gives more information, specifically:

Note that even though by default, API calls are made from the server, a description of the call is sent to the browser and are thus visible to a savvy user. This means that any sensitive parts of the call, especially secrets / tokens, should be in fields marked “Private”.

1 Like