Byte to megabyte converter (BUG? how to calculate)

I’ve been struggling for a few hours (over 24 hours) with something that should be relatively simple.

User uploads a file, saving the size of that file in a record. The bubble was saved in BYTE.

When I start the calculation, bubble considers it a floating number and not an integer.

Example on a common calculator:
Byte: 2934209 / 1024^2 = 2.7982797623 MB

How bubble calculates:
Byte: 2,934,209 / 1024^2 = 0.00000821073766296482086181640625 MB

I DON’T UNDERSTAND!

How do I turn this into megabytes?

My application offers storage space to users and I need to show them how much they have used of the total they have.

TRANSLATED WITH GOOGLE TRANSLATOR

What is 1024^2 as a number? Perhaps use that?

What exactly are you doing? I just tried 2,934,209 / 1024^2 in Bubble and it gives the correct answer (as expected) of 2.79827976226807

I’ve got no idea how you’re getting 0.00000821073766296482086181640625, so what exactly are you doing to get that result?

I am grateful to everyone for the help.

I tried to calculate it directly in the workflow when I get the file size and I tried it from the front end.

Below are screenshots of the bubble:
bubble