CSV upload - Undefined error. HELP!

Hi everyone, I need some desperate help>

I’m trying to upload a csv file. This csv file has worked before but now I get the following error:
“Import of ‘x’ file failed with the following error: undefined”

It is simply 10 rows of data, that all link correctly and validate.

Has anyone had this issue before? I have no idea how to troubleshoot this.

I am having this issue as well. Not sure how to solve it yet. I have successfully uploaded CSV files before without this issue. Let me know if you figure it out!

I encountered this error as well. Try checking your email for the import status, the reason could be there.

2 Likes

@nocodejordan’s advice was spot on. I checked my email, and it said that my .csv was not formatted as UTF-8 encoding… So I googled how to do that and it led me to this video (watch it):
https://youtu.be/a6iwPJVh5-k
I basically did what it said. When I imported into Bubble, I made sure that it said “tab” for the delimiter instead of comma and that the file had a new name. And then it worked!!

6 Likes

I felt so embarassed on this. I checked my emails and it gave information on geocoding issues.

Turns out, we had our sever and client side API keys the wrong way round on geocode.

To everyone else - the emails actually give an error, whereas bubble often says ‘undefined’!

To everyone else - the emails actually give an error, whereas bubble often says ‘undefined’!

It’s a recent bug, it didn’t work like this before. Someone can do a public service to send a bug report to Bubble :slight_smile:

This worked - thank you so much!

1 Like

FYI it is easier now with Excel. Simply hit Save As and select UTF 8 csv type.

2 Likes

That wasn’t the fix in this case - we were uploading as csv but thanks!

Hi James, I was having issues uploading as csv as well and stumbled upon this thread on google.

For the sake of future readers and to clarify, my solution proposed above refers to how to get around a undefined error when uploading a csv that Bubble informs you in the email it is having issues with UTF8 encoding as discussed in this answer in the thread. CSV upload - Undefined error. HELP! - #4 by marcusfarmer44

To avoid having to do all of that, just follow my instructions above.

Cheers

you are a boss for sharing, thanks

1 Like

Champion advice Marcus - thanks for sharing! I checked my excel file format and re-saved it as a UTF-8 format and it uploaded like a charm…

Crazy, I submitted a bug report and was sent to this thread to find a solution. Saving as UTF8 and renaming it worked, but I don’t understand.

I exported data from Bubble and got a excel csv file directly from file manager. I used that file, mostly for the column headers and added new data, about 500 rows. I simply saved the file in the same format that Bubble exported the data. This works 99% of the time, but not this time. I got the error mentioned above.

So while waiting for Bubble to respond, I tried to upload just the first 100 rows and it worked. So I did the next 100 and so on. I had 5 files in all and 4 out of 5 worked just fine. But the 4th file never worked. I just did saved this file as UTF8 and renamed it and it uploaded as expected.

Why would 4 out of 5 work fine and not one of them, but then save a little differently and it works?

It’s like a referee who makes consistent calls all game and then for some reason on one call decides to make a random bad call?? Not sure how to play the game with inconsistent results!!