Custom font function doesn't work

Good day,

I’m using the latest version of Bubble (Oct 03, 2020).
I have tried to upload a custom font, but it did not work. Is there any issues with this function?
Here’s the screenshot and the link to the font.

Thanks a lot !

1 Like

When you say this, does that mean it didn’t show up in any of your font pickers in text elements, etc?

Hi @Eugene :slight_smile:

Welcome to the Forum! The steps to upload a custom font are a little tricky - this is the current method that I use:

  1. Upload the font file itself in the Bubble editor using a file uploader:

  2. Copy the uploaded file’s s3 address to your clipboard

  3. Create a new CSS file and paste the URL from Step 2 as the font’s source URL (here is my example using a font called Mier A Regular)

  4. Save the CSS file to your computer

  5. Upload the CSS file itself in the Bubble editor using a file uploader, and copy the generated s3 URL:

  6. In the app editor where you can add fonts, enter the Font Name as it appears in your CSS file. Then, Paste the s3 URL into the CSS file path input (that you copied from Step 5)

  7. Click “Add Font” (The font name should be displayed in the font itself if it was uploaded correctly)

That should work, but feel free to let me know if I can clarify anything or if you have any questions! :slight_smile:

Hi Johnny and fayewatson,

Thanks for the instruction. I did follow the exact steps you have provided prior to my post, as I have watched this vide: Seems to be a very clear explanation. In this video Waltograph style is visible as soon as the font is uploaded, which is not my case.

When I stated “It did not no work”, what I meant was that the font is visible in the font selection drop down (please see attached screenshot), but when I select it the text in the text box does not get changed to Waltograph Disney style.


I tried other existing fonts and they work fine. I believe something is wrong with this function, but not sure.

Thanks again,

Hi @Eugene :slight_smile: Got it!

It looks like the font name needs to be “WaltographRegular” instead of “WALTOGRAPH DISNEY”, with the CSS file path of “”. If you re-add the font with those changes does that fix it?

Hi fayewatson,

Thanks a lot. It did work!
So, the lesson to learn is to open URL link to check the exact name.
Thanks a lot, again. Much appreciated.

Best regards,

This topic was automatically closed after 70 days. New replies are no longer allowed.