Date fields have issues, they don't stay open, and I can't go back past 2014

Hi everyone, one more issue this morning. I’m having trouble with date input fields. I made a GIF here that shows what I mean:


Whenever you click in the field it just pops up for half a second then closes. On another app I made that was totally different I had some users complain of this but I never had this issue in Chrome (they were on Chrome also). I made a new app now, and when testing it now I’m getting the issue. When you click in the field the calendar just appears for a split second and closes, unless you keep the mouse button held down.

The second issue is when it does work, I can’t go to a date prior to 2014 as it just starts on January 1 2014. We need to be able to enter dates from 2001, 2003, etc.


Hey there, I want to see if I can try to duplicate the problem. What are your calendar settings? :slight_smile:

Hi there for sure thanks! I’m actually trying it now and the calendar stays open. I never had this issue but people on my team did, but in terms of the year 2014 is as far back as I can go.

Here’s the settings!


Is your date on your computer correct? Is something blocking it? The date says 1/15/2013. That should say todays date. Makes me think there is something wrong with the date/time of your browser or computer.

Date and time are correct on my computer, but I use multiple PCs as well so it does it on all of them. Even though it shows 2013 in the screenshot you can’t go back that far when actually using it. 2014 is the farthest back it lets you go when picking a date.

Just curious, did you ever have anything in the “minimum date” or “maximum date” fields? Even though they appear empty in the screenshots, I’ve seen fields like this that still hold a sort of undefined value. When I encountered that, I right-clicked the fields and selected “clear expression”. Seems redundant but worked for me in similar situations, worth a try.

No I’ve never used those.

The calendar closing when you open it is more random, right now it works for me but does it always for one of my employees. But not being able to go prior to 2014 has always happened. It does it on every app I make so I assumed it was some kind of setting.

Try clicking on auto-binding and see if there are any fields that show up there that you might need to delete. Have you tried replacing the element and seeing if it gives you the same issue? So weird.

The Initial content field too. Whether you did or didn’t have values in them, right-click “clear expression” for any blank fields. FWIW I’ve now trained myself to never use backspace/delete, always “clear expression” in any field that you can insert dynamic data, even if I just click the field by mistake and don’t enter anything I use clear expression to be sure.

I haven’t been doing that but it’s a good idea as I noticed that earlier on a bunch of fields I copied/pasted, they would be currency or text fields but they’d have a value in them even though that had been cleared so I had to delete the field and start over so that’s good to know. I never had an initial value in this one though but tried anyway. Still does the same thing, 2014 is as far back as you can go:


select 2014, then earlier dates will appear

Ah thank you! That’s so confusing to think it works like that as none of my users knew that. It’s still doing the annoying thing where the popup won’t stay open though had to refresh a bunch of times and then it finally stayed open. So weird not sure why it does that.

it is a poorly designed element, if important to your UI/UX look for a plugin date picker. I’ve never used a datepicker but do recall lots of complaints about the built-in one.

Re: clearing the fields, I was thinking that could be causing the rapid closing. If not, maybe try removing transition animations, when animations “collide” you get that symptom.

Also don’t understand why there is a scrollbar in the datepicker, that may also be the source of the rapid closing. That is probably being added by the browser, like the browser is interpreting that a scrollbar is needed in this group for some reason… maybe try resizing the element, wider/taller? I suspect that if you can get rid of the scrollbar it may also get rid of the rapid closing problem.

May also depend on the scroll position of your page, ie, if the broswer is pushing the dropdown higher (as it appears to be in your .gif) that may be causing the problem. Normally, the dropdown will be below the input box.

Just a quick update, using a plugin was a great idea as there are some cool ones that look pretty awesome, so that solved the problem!

Glad you can keep moving forward! Sometimes there are quick fixes, sometimes not so much.