Input: Text (Numbers Only) validation issue


While creating a form to collect a user’s SSN to be converted by Stripe, I added an input field and set the content format to “Text (numbers only)”. I also set the limit of characters to 9.

Without adding any new conditionals, or changing anything else, it seems that whenever I try to fill in this input in test mode, it thinks it is invalid as indicated by it’s borders highlighting in red from Bubble’s pre-built conditional. This weird invalidation issue is also causing problems with me creating other workflows or conditionals based on the content of an input field.

Has anyone else been experiencing this issue with input fields over the last few days?

1 Like

I’ve renamed the original post because I figured out what the issue was.

It seems to be specifically whenever Is set an input field’s content format to Text (numbers only) or Integer. When this happens, anything I enter in the fields are invalid. When I change the content type to just text, they seem to be valid and also enable their conditionals.

While this is a workaround, I would prefer to limit users to only entering numbers whenever necessary like in the event of entering a routing number or SSN.

Is this something other people are experiencing?

Did you figure this out? I’m having the same issue but I want to enable international phone numbers, which sometimes have more digits than the U.S., plus a country code.

Unfortunately I did not.

I reported the bug to @Bubble but they suggested that I troubleshoot the issue with Stripe plugin by @copilot. This is because the form I built is meant to collect the SSN, Routing number and account number to create a seller in Stripe.

However I told them that I do not believe the problem is with Stripe, since its more with the input fields. And now that you’re telling me that you are experiencing the same issue, I know that its more on Bubble’s side. I told them, so hopefully they get back to me soon.

1 Like

Hello again,

I’ve seemed to resolve my particular issue simply by unchecking the “this input should not be empty” option.

For some reason, whenever this was selected, I could not use any input content format other than “Text”. But once I removed that option, I was able to successfully use the “Text (numbers only)” content format and complete my forms.

I’m not sure why this happened because in a previously built version of this app and form, these settings are selected and the inputs work fine.

Hopefully this resolves your issue.

1 Like

Hmm…I don’t have “this input should not be empty” checked at all. Strange. I keep getting “value should be a number but right now it is a text.” This may be a bug, too?


I have noticed a few bugs lately. This one was strange but support kept insisting that the issue was with the Stripe.js plugin and I knew it wasnt. I even removed the StripeToken and deleted all of its workflows just to test and was receiving the same issue with filling out number only text inputs. It wasnt until I unchecked that option that it worked.

Got it. How do I reach out to support?

Hi there. Bumping this issue, as I am having the same problem: when a field has “This input should not be empty” selected, and the Content format set to “number” the automatic validator always marks the input as “non valid”.

I am playing around with the Tasky Project Management template, and there is no Stripe plugin there. However, there is a series of different plugins installed, maybe one of them is interfering?

Those of you that are having this issue, are you using any of the plugins below? If so maybe one of them is causing the problem?