Need help with a dwolla error message in a plaid get access token action

NEW NEW NEW user here. I’m attempting to modify our app to use the v2 of the Plain plugin, but I’m getting an error message that I do NOT understand why it is occurring. I want to show the steps in the action and hope someone can see why it is breaking. Here we go…

preface: I’ve already added the Plaid plugin to the page, titled it Plaid A, so I’ll start with the actions. The action begins in the event where the user clicks the dwolla popup authorization’s ‘accept’ button.

  1. First I save ‘yes’ to the popup authorization’s custom state ‘authorized’:
  2. I’ve added the Plaid Create Link Token action:

  1. Added the Get bank account with Plaid A action:
  2. In the Group Bank Account’s List , in the custom state dwolla_authorization, I also save the Popup Authorization custom state authorized value.

5 & 6.
Hide the popup authorization and show the ‘loading’ ellipsis.

On to the event When Plaid A token has been created:

  1. Plaid - Get access token

Finally we are down to where the actual problem is. According to my documentation the public token has been deprecated in the Plaid plugin for the link token, but I can’t find a Plaid - get link token action to replace the Plaid - get access token action. So when this action fires I get this beastly error message:

*Plugin action Dwolla - Create Funding Source (With Authorization) error: *
Error: {“code”:“NotFound”,“message”:“The requested resource was not found.”}

  • at errorFrom (/var/task/node_modules/dwolla-v2/src/dwolla/Token.js:49:15)*
  • at /var/task/node_modules/dwolla-v2/src/dwolla/Token.js:70:29*
  • at tryCatcher (/var/task/node_modules/bluebird/js/release/util.js:16:23)*
  • at Promise._settlePromiseFromHandler (/var/task/node_modules/bluebird/js/release/promise.js:547:31)*
  • at Promise._settlePromise (/var/task/node_modules/bluebird/js/release/promise.js:604:18)*
  • at Promise._settlePromise0 (/var/task/node_modules/bluebird/js/release/promise.js:649:10)*
  • at Promise._settlePromises (/var/task/node_modules/bluebird/js/release/promise.js:729:18)*
  • at _drainQueueStep (/var/task/node_modules/bluebird/js/release/async.js:93:12)*
  • at _drainQueue (/var/task/node_modules/bluebird/js/release/async.js:86:9)*
  • at Async._drainQueues (/var/task/node_modules/bluebird/js/release/async.js:102:5)*
  • at Immediate.Async.drainQueues [as _onImmediate] (/var/task/node_modules/bluebird/js/release/async.js:15:14)*
  • at processImmediate (internal/timers.js:461:21)*

Error: Outer Error (see above for inner error)

  • at Block.wait (/var/task/u.js:420:34)*
  • at Object.async_fn [as async] (/var/task/index.js:302:35)*
  • at eval (eval at build_function (/var/task/index.js:72:21), :26:22)*
  • at /var/task/index.js:335:23*
  • at run_fn (/var/task/u.js:594:18)*

I do not understand why it is showing a Dwolla error message in a Plaid action. The actual Create Funding Source (With Authorization) action does not occur until step 6 in the workflow:

The error message ‘The requested resource was not found.’ doesn’t tell me anything about what resource it is expecting.

Can anyone tell me how to rectify this situation?

Maybe tag on this thread and check out the examples? (if you haven’t already?) When you get an error in a Plugin it’s probably only the plugin developer who can help unless someone has seen and solved the exact same problem.

For a new new new user you’ve got quite far! The first sentence in the plugin doc says “Works only for US users” - are you in the US?

Yes, deep in the dark sub-tropical jungles of Alabama! I’ve been at this for less than a month. The question is: what am I missing here? I can’t use a link token in the Plaid - Get access token action, it’s not available as an option, only public key (which is now supposed to be deprecated).

Hey @madisonconaway a few things here:

  1. Check out this other Plaid plugin Plaid (up-to-date for OAuth) Plugin | Bubble. It’s MUCH more stable and fully featured than the Plaid plugin you’re using. It also comes with free video how-tos.
  2. I’ve tried using that Dwolla plugin from Zeroqode without great success. So much so that I have been attempting to build my own plugin for Dwolla specifically to work with Plaid. Dwolla’s APIs are not super friendly to work with. If you have another option for a payments provider, I’d highly suggest trying them out.
  3. I’ve not put that Dwolla plugin up on the marketplace yet because I’ve not successfully gotten Dwolla to allow me to go live with it (though at least in theory, the plugin works). They are throwing up Bubble security roadblocks, among other things. That said, I’m happy to share the plugin with you - DM me and I can add you to it. Maybe you’ll have better luck.