Forum Academy Marketplace Showcase Pricing Features

Privacy rule - search but no view rule

Hi bubblers,
I am new bubbler and pls forgive if this is obvious…
I am working on my privacy rules and recently figured out that bubble’s search shows up all data from the table (thing) (in the browser’s developer tool)…well, guess all knows about it :slight_smile:
So, I am working on my privacy rule to set up…but have this issue - there is a field that I use in the search, but I do not want user to be able to see it…at example–user status (active, not active)…I use it in the search but not want the user to be able to view it (in the browser’s tool of course)…I am not showing it on the app screen, but it is visible in the browser background…
Pls help!!!
Thanks!!!

So have you already used the privacy rule to hide the user status? If yes, what condition did you use in the privacy rule?

yes, condition - when current user is logged in - I have view and search for all, and everyone else (that is where is the problem) - i do not want users that are not logged in to see this field, but I want to be able to show to them search results that use this field as a condition…
so, in everyone else rules - if I, for view fields turn off status, my search does not work…
any help?

Uncheck “View All Fields” and then below, check one-by-one only those fields that the user will need to see.

Keep “Find this in Searches” checked

Hi,
thanks for help…that is what I am doing exactly… I do not want user to see the status field…and I do not check it in the view area.
but, my search that uses status field, then does not work…

If the find in search is checked, it should work.

Can you add some screen shots of your privacy rules here?

1 Like

Hi Robert,
thanks for helping…here I will post some screenshots…
CASE 1 (privacy rule and fields included for view (which I do not want) (fields are marked)
image
and the RG returns results.

CASE 2 - Privacy rule - fields excluded for the view (which is what I want)
image

but, there is no results in the RG.

And, this is in the WF where I use the up fields:
image


Any clue? Thanks a lot again for trying to help!!!

How is the repeating group sourcing the data?

Because if it is referencing a value that is no longer visible, that could be the problem.

Hi Robert,
now analyzing this problem to give you the answer, I have figured out following:
the RG source itself does not referencing any ‘not visible’ field…but, the WF does…in the WF, I have the condition to terminate the workflow (and further not populate RG) if the condition that referencing ‘unvisible’ field is true…so, actually I have a problem in this condition and WF…
any thoughts on solution?
TNX A LOT!!!

Without seeing the workflow, it’s difficult to say. 99% of the time, there is a way to fix it directly or at least, do a workaround.
You could try to create another field that is visible and correlates to the invisible one, as in a yes/no condition, but without exposing the info you don’t want to be exposed and use that in the workflow.
Alternatively, you could use the Set State action earlier in the workflow, and then terminate later based on the State.

Good luck.