RG not displaying images from custom state

I’ve got some funky behavior going on between a custom state (list of images) and a RG (which displays the images in the custom state).

How it should work:

  1. Upload image(s)
  2. Save images (triggers workflow)
    a. Set custom state (multi-file uploader’s value’s URL)
    b. Show popup that contains the RG, which is set to display the custom state list of images from “a”.
    c. Images in RG show up properly and everything is hunky dory.

How it actually works:

  1. Upload image(s)
  2. Save Images (triggers workflow)
    a. Set custom state (multi-file uploader’s value’s URL) - this works just fine.
    b. Show popup that contains the RG, which is set to display the custom state list of images from “a”. - this works just fine.
    c. Though the state is populated with images AND RG is set to the proper data source, images do not show up in RG.

I also checked out the elements in debug mode and everything looks like it should work:

  1. Custom state:
    The custom state is being populated properly with a list of images.

  2. Repeating group:
    The repeating group is properly set to display the list of images in the custom state. However, it shows the list of images as empty.

Any thoughts would be appreciated. If anyone is having the same issue/can reproduce the issue, I can submit a bug report. Until then, I’m stumped.

Link to editor:


Edit: This same “Image → custom state → RG” workflow is working elsewhere in my app, it’s just this use case (with the use of a popup) that is having the issue.

This topic was automatically closed after 14 days. New replies are no longer allowed.