Forum Academy Marketplace Showcase Pricing Features

🥠 SalesForce API Connector - New Plugin from Zeroqode

salesforce-logo

This plugin connects to your Salesforce account and exchanges data with the Bubble application.

For details, screenshots and demos please visit the plugin page: at https://zeroqode.com/plugin/salesforce-api-connector-1545963069108x315329958229049340

Levon Terteryan

Founder @ Zeroqode

zeroqode-for-web-160x120

Bubble Templates

Bubble Plugins

Bubble Courses

Convert Web to iOS & Android

No-code Development Services

4 Likes

Forgive me if this sounds silly, however, I was wondering whether I could use this plugin to create a new user from Salesforce or at least a new data type?

Hello there @jamesbond, we don’t have this type of actions in our plugin, we will analyse use cases of that functionality and then maybe we will add this calls on the next update, but you have to know that we have other priorities.

Thank you,
Best Regards,
Nik.

1 Like

Hi, Levon! I bought this plugin, configured everything according to the instructions. Everything works on the demo page, but not on my page. An error occurs during authorization: error = redirect_uri_mismatch & error_description = redirect_uri% 20must% 20match% 20configuration
I’ll be grateful for the hint! What I’m doing wrong?

Hello @akrylov,

Thank you for reaching out!

We will inspect the issue and will do our best to provide a solution ASAP.

Best Regards,
Zeroqode Team.

Hi @ZeroqodeSupport I purchased this plugin but receive this error when attempting to use it:

The service SalesForce - Create Lead just returned an error (HTTP 401). Please contact the plugin author directly for feedback. Raw error:

[{"message":"Session expired or invalid","errorCode":"INVALID_SESSION_ID"}]

I’ve been trying to receive support from your team but they have not responded? Is this plugin not supported anymore?

I’ve noticed the demo pages are broken as well.

Hello @nonofrio

Thanks for reporting and sorry for the issue. Let us check this out and be back to you asap.
Thanks for understanding.

Regards,
ZQ Team.

Are there any updates?

Hello @ZeroqodeSupport are you able to assist?

Hello @nonofrio

Sorry for taking so long, we’re working on it. Please bear with us here, we’ll notify you here or on our forum asap.
Thanks for understanding.

KR,
Zeroqode Team.

Hello everyone @nonofrio @akrylov

Thanks for patience.

We updated the plugin setup documentation for plugin, which seem to mislead users. Please check out - https://docs.zeroqode.com/plugins/salesforce-api-plugin
Really sorry for this.

Please check out the setup documentation , and try out our demo setup to replicate it - https://bubble.io/page?type=page&name=salesforce_demo&id=zeroqode-demo-11&tab=tabs-1

Once it’s set, wait around 10-15 minutes in order to establish the connection between app and salesforce.

Thanks for patience and understanding.

Regards,
Zeroqode Team

Love this! We’re actually about to do this from scratch for Announcefly. @levon, does the plugin support the end user connecting their account or is this possible? I.e we’d like our users to be able to connect their Salesforce account to our SaaS so they can export data to it.

@ZeroqodeSupport @levon It seems that adding details about the callback URI is helpful, however it does not support a domain as the plugin directs the user to login.salesforce.com which doesnot work when a subdomain is used and the user needs to login at https://subdomain.my.​salesforce.com/

Is there any workaround for subdomains?

Hello everyone.

Believe you’ll need to setup that up under your application dashboard.
Here are some resources which should be helpful to understand the plugin oauth method, also information regarding domain setup and usage:
https://help.salesforce.com/articleView?id=remoteaccess_oauth_user_agent_flow.htm&type=5
https://help.salesforce.com/articleView?id=remoteaccess_authenticate_overview.htm&type=0
https://help.salesforce.com/articleView?id=domain_name_setting_login_policy.htm&type=5
https://help.salesforce.com/articleView?id=domain_name_app_url_changes.htm&type=5

For testing purposes we registered the domain in salesforce dashboard (zq-dev) the old you could see in the address bar we have the old url (eu25):

Once you set and register your domain, wait for about 10-15 minutes to be up and running and start testing.

Once you’ve tested, Deploy it to Live now you can edit the permissions for login.

Please check this out. Hope it helps.

Regards,
Zeroqode Team.

Hello Zeroqode
When going to doc : https://docs.zeroqode.com/plugins/salesforce-api-plugin,
all the links to the screen captures are broken.
Could you update them ?

When trying to log to my salesforce, i’ve got the following error : “OAUTH_APPROVAL_ERROR_GENERIC” and error_description=the+requested+scope+is+not+allowed

(but it works when logged from you test app)

could you help me fix that ?
Regards
Michael

Hello
i’m having the exact same issue. How did you solve it ?
Best
Michael

Hi @michael.kazmierczak,

Thanks for reaching out. We can see an open thread here. We’ll monitor this one for further updates.

Best regards,
Zeroqode Team

Hey Team @ZeroqodeSupport - it looks like the Oauth scope options have changed here since you made the manual. Any idea which we should be including for the plugin to work as intended here?


Hi team @ZeroqodeSupport - a bit more information on the above. I’ve chosen what I think is the best option on the Scope side here and I’m getting a “requested scope is not allowed” error message. I’m guessing that the scope request is coming from within your plugin, so it would be good to know what you’re sending so I can solve this.

I’ve tried to log in to your forum on your site, but your changed login flow won’t let me either log in or sign up with my existing credentials, which is why I’m trying to address this here instead.

Hello, @brian
Thanks for reaching out and using our plugin.

We carefully analyzed your requirements and would like to note the next points:

  • The issue from the screenshot is related not to the plugin functionality, but to the authorization in your SalesForce account. It can be related to your credentials or access. Thus, please check this thing :pray:
  • Please make sure you have added the required Available OAuth Scopes to your account, like:

For our Demo Page, we are using the next ones:

However, you can select only what you need :pray:

  • Do not forget to enable the Redirect URL in your SalesForce account;
  • Check the keys in the plugin’s tab.

Please check all of this and let us know about the result.

Best regards,
Zeroqode Support Team

1 Like