Forum Academy Marketplace Showcase Pricing Features

Send TEXT message to unique numbres

Hello Co-Bubblers.

In my app people can send a text message to whoever they want.
However, when they have already texted a certain number before, they can not text that number again.

Yet, other users are still able to text that number.

Basically, I need a workflow that triggers only when ‘Current user’s phone numbers is not yet used’. And if they have already texted that person, an alert has to remind them of it.

How do I create such a workflow? I’ve read a few other topics about making sure that users have a unique username. Yet I’m still not able to figure this out.

Hopefully you, yes you who is reading this post right now ;-), can help me with this little workflow.

Thanks in advance!

Hey Oliver, are you using a plugin? Or is it a direct integration? And is it with Twilio?

We let our users text message phone numbers and have never had an issue like this. Can you attach screen shots of the current Workflow? I’m curious what’s preventing it from sending multiple times.

Hi
I assume that the “once only” is your policy, not a bug.
You need a log of who has texted who, in a table, and then you set a condition on your workflow when
Do a search for “numbers people have texted”
Where user is current user
And number is “the number the user wants to text”
:count is 0

Hi @armcburn, Thank you for your answer. I re-read my thread and I can see the confusion here. I did not state this very well from my end. I meant to say that I would like to prevent users to send the same person a text message again. It’s not a bug. :slight_smile:

By the way, are you using the Twilio plugin, and do you like it? Currently, I am using Zapier + Clicksend, which is working really fine. But Zapier is pretty expensive when it comes down to adding extra tasks/month. Do you recommend just using Twilio?

Yes I’m trying something out like this but I can’t seem to figure this out. Do you happen to have a little demo? Thanks in advance! :slight_smile:

@richard10 @armcburn

This was literally working like a charm! When the same number was submitted after it was created before, the button would not be clickable.

After logging into a new account, it suddenly does not work again. Is this a bug? Or how do I fix this? Thanks in advance!

Ah. got it.

We use Twilio but through the API Connector, not a 3rd party plugin. Twilio’s interface is incredibly intuitive. It’s built in a “low code” manner itself, so I found it nice to use. At least the elements that I needed.

In terms of how we did it, we simply have an “only when” condition on the API call to see if the user in question has sent a text to that number before. In our use case, we create a unique “contact” record and then form a “contact request” which fires off to the API, if that makes sense.

So basically the logic is… If User sends a text request… it checks to see if a contact exists with that phone number, and if it exists, then it doesn’t do anything basically

1 Like

Could there be two snuck in there at some point on your test accounts? Are you always texting your same number?
Your criteria are if it’s exactly 1 record found, you can’t click. If there were 2 it would be clickable.
It’s not something stupid like that is it? Change it to not zero?

1 Like

I finally got it to work. Thank you for your help!

By the way, @armcburn is it possible to schedule a Twilio message from within Bubble? Currently, I use Zapier’s ‘Delay’ function that I combine with a custom state from Bubble to let the user choose how big this delay should be. Is it something you know can be achieved without using Zapier?

Put it in an api workflow. You can schedule those for any time you want.

1 Like

Those run daily right? For my use case, they should run hourly or even within 30min.

In your workflow, there’s an action “schedule an api workflow”
With a precise timing of your choice
E.g on a date you choose, based on a field, or current time +1 minute or hour or day, you can nest those, so current time +1 hour +20 minutes +1 second

API workflows don’t run on the page, so you have to configure them and pass in all the needed parameters that the workflow will need to run when it finally comes time to run it.

2 Likes

Richard nailed it. I believe you’ll need to be on a plan that allows back-end workflows , so keep that in mind.

2 Likes

Oh I see! This looks promising. I’m going to play around with it. Thank you for your help! :slight_smile:

@armcburn @richard10
Sorry to bother you again guys, but is this about right? I did not upgrade my plan yet so I can’t test it myself…

Really appreciate your help! :slight_smile:


Nearly.

Your api workflow needs to be set up to have parameters for the name, number, content in it.

The clicksend SMS action lives inside the api workflow so it executes at the scheduled time

The page is dead and gone by then. So the workflow needs to have been passed in everything it needs to execute at your desired time.

I see, thanks!

I already have one parameter, on screenshot 1 it’s the ‘phone = input phone’s value’.
So now I will have to add one more which is the message (body)?

You need to be able to fill in every field in the SMS Request. The page is gone. If you put the action in the step, you’ll soon figure out which info you’re short of at run time. You need to pass everything.

Plus if you have an api workflow you pass everything to, you can reuse it.

1 Like

Thank you for your answer! Guess I have to upgrade my plan and see where I’m falling short. :wink:

Hi All, I wanted to share that I found a solution for my issue which was setting up a daily workflow with bubble because I only have the personal plan. Well, I found a company that has an api that will send out text messages or emails as often as you like and is incredibly affordable if the other option is to upgrade for this one feature. Here is the link for the api workflow ( Yardillo API Documentation (yardillo-yardillo-default) | RapidAPI ). Milind is the owner and can help with any api. I know because I just completed the process with him and it works beautifully!!