The information from my database is not being shown on a pop up

Hey Guys, how’s it going?

At first, the app I was building was ok-ish on the preview mode, I could actually see the DB information on the popup screen. But now, I can’t and I have no idea why. Does anyone know how to solve this? Thank you.

That’s the info it is supposed to show:

That’s what I get:

Hi there, @pedromarcoms…it’s going to be difficult for anyone to help without seeing screenshots of your setup or (ideally) being able to poke around under the hood via a read-only link to your editor. It is interesting, though, that there are a couple of characters showing on the left-hand side. Do you know if those characters are part of a field’s value from the database?


Yeaah it’s a common issue with beginners BUT I’m experiencing the similar issues.

I guess Bubble is making some updates? … In my case basic MAKE CHANGES TO CURRENT USER doesn’t work… I’m about to go crazy here

Hi Mike!

It is the only info not coming from the database.
How can I get this read only link?
I still haven’t deployed the app.



If they’re making some changes, it would be nice letting us know in advance x)

Go to the Settings >> General tab, change Editor access permissions to Everyone can view, and copy the URL to the relevant page in the editor and paste it into a message here.

What’s a common issue with beginners? We don’t even know what the issue is. :wink:

1 Like

Display the right content. The issue @pedromarcoms is experiencing is one of the following:

  1. Group or groups in the Popup miss the datasource
  2. Before popup is displayed the data is not sent
  3. Privacy Rules prohibit data to be viewed by other users
  • if none of the above then data might be missing itself or the wrong data is sent etc.

:point_up_2: this is what I mean when I say common mistake. Wink back atcha :wink:

Hi Mike, here it is!

You said the popup was showing data before (which is why I wasn’t sure if it would be any of the things Gio mentioned), but I don’t see how it could have ever worked because, as Gio said, the popup doesn’t have a data source, and the workflow that shows the popup doesn’t have a step to display data in the popup. So, try adding a step to the workflow with the Display data action, and set the data to display as the Current cell's Product.


Mike!!! It worked!
Adding the display data on the workflow was the one thing missing!
For sure I did not pay attention to that when I deleted the pop up and created again.

Thank you @mikeloc and @bestbubbledev


Glad to hear it’s working… happy to help. Oh, and make sure to set your app back to private now.

1 Like