Toasty notification - ReferenceError: toastr is not defined

Hi everyone.
I’m experiencing an issue with the plugin Toasty notification
ReferenceError: toastr is not defined
I just set up the action “Toasty notification” in my workflow to be triggered when I hit on a button as you can see on the screenshot.

And when I hit on my button, nothing’s happening, I can just notice the issue in the workflow debugger:

Has anyone encountered this issue? @AliFarahat do you have any idea about this please?


Hey there.

From the screenshot above did you set the extended timeout in the workflow? It looks like it’s empty

Try setting a number there and let me know if your still facing an issue.

Thanks for replying so quickly.
Yes I tried with and without value (as well as dynamic value) in the Extended Timeout field. I got the same result.
I also tried with all kind of combinations (check/uncheck “Newest on top”, “Close Button” etc… with all other fields): unfortunately still the same result.

I will do some internal tests here and get back to you. So far no one else reported an error. It maybe related to the new minification that was added recently to the plugins but I could be wrong.

I did some testing, and everything is working fine. Try to upgrade to te latest edition or maybe uninstall and re-install. I will also check if you have any custom JS interfering with it

Send me a direct link to your editor so i can examine this further

Thanks a lot.
It appears actually this issue was related to my app: I just tested it on another app with a lot less plugins installed on it.
As you said it looks like either some JS or my other installed plugins were probably interfering with this one.
Either way here is the url where I encounter the issue:

Anyway, thanks again! I know now it’s related to my app, I should be able to figure it out by uninstalling other unused plugins and other messy stuff I might have. I’ll let you know the origin of the conflict if I’ll figure this.

1 Like

Yes please let me know

Hi @AliFarahat.
I finally find out the origin of this issue. Sorry it took 2 weeks, I was working on something else meanwhile.
Anyway the issue was related to the conflict with One-Signal - Web Notifications plugin.
I guess it make sense since it’s a notification plugin as well…

Hope that helps.

1 Like

Thanks for the help. I will reach out to the author and see what we can do about this. In the meantime the pro version uses a completely different core js library. If you want to give it a rest run let me know by private message your app name and I will grant you a trial access.

I’m also getting an error on my app, since I just installed to see if it fits my needs.

Lot of errors like these:

anonymous@ line 99 > Function:4:1 T/</<@ A@

I do not have One-Signal installed, but on a fresh app I have no issues. So for sure there is some interference. Will try to check, but most of it I actually need so not much I can weed out. :slight_smile:

What happens is: on trigger, the progress bar starts running but nothing happens and never finishes. It generates the error above.
I deleted all plugins I dont use, i created an empty new page with just one button on triggering the plugin, but still the same behaviour.

Hey there.

I am not aware of this. Do you want to give the pro version a try. It uses a different JS library than the free version.

Direct message me with your app name to give it a spin

It would also be nice to gain access to the app so I can try to debug this problem

This topic was automatically closed after 70 days. New replies are no longer allowed.